1

Dell Vostro 2520 laptop
Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
2- Cirrus Logic High Definition Audio, model CS4213
Ubuntu 18.04.4
Windows 10 Home, v. 1903, bld 18362.778
Skype 8.59 (Ubu & Win)
Zoom (cloud meetings) 5.0.3x (Ubu), 5.0.1x (Win)

The Covid-19 virus now means that I am trying to do a lot of stuff from home, but Skype and Zoom don't pick up my voice via the inbuilt microphone.

Whenever I switch on my Dell Vostro laptop or awaken it from sleep, the microphone is switched off. However, in Settings > Sound > Input tab, it is shown as switched on, but the bars of the level meter do not light up when I speak. PulseAudio Volume Control and Sound Recorder do not show any activity either.

However, if I switch the microphone off and then on again, the sound bars do light up and Sound Recorder is able to record and play back. But in Pulse Audio Volume Control, the Recording tab does not list Sound Recorder.

A test call in Skype (on both Windows and Ubuntu) does not record sound, even though PulseAudio Volume Control shows that it is recording. In Zoom, the Settings icon > Audio > Microphone settings shows the level meter working, and PulseAudio Volume Control also shows that it is recording.

When I put the laptop to sleep or switch it off, on awakening or boot, the microphone is shown as still switched on but it is actually disabled and none of the control apps show any activity.

Does anyone know how to preserve the microphone state set by the On/Off slider in Settings > Sound, and to let apps access the microphone? What further system information will help?

This is clearly a software API problem as the Sound Recorder, PulseAudio Volume Control, and Settings > Sound apps are able to pick up the microphone output.

Notes

Many days searching the internet and AskUbuntu have not produced a solution that works. (For what it is worth, many posters have reported that sound became dysfunctional after upgrading to 18.04 or 18.04.4.) Here is what I have done:

  • I have added the snd-cs46xx kernel module and firmware to get around driver licensing issues following the instructions at https://wiki.debian.org/snd-cs46xx, Debian 8.

  • To /etc/modprobe.d/alsa-base.conf I have added these lines:

    options snd-hda-intel model=dell-vostro-2520  
    options snd-hda-intel dmic_detect=0  
    
  • In PulseAudio Volume Control I have set the following:

    Input Devices Port: Internal Microphone
    Output Devices Port: Speakers

0

I have a somewhat similar problem. My microphone does work, but once (and only once) did the microphone test (Sound -> Input) work. Also, the bar graph for that test is now much smaller in width than it was when it worked.

More info regarding microphone test (Settings -> Sound -> Input) in Ubuntu 18.04 with Gnome.

  1. Test shows with bar graph approx. 14 cm wide on my screen. Bar graph responds when I talk into mic.
  2. I exit Settings and then return to microphone test. This is the only change I make. Bar graph is now about 3.25 cm wide on my screen and it does not respond when I talk into mic.
  3. I click on "Bluetooth" in Settings. It says "Bluetooth not found". I do nothing else.
  4. I return to Sound -> Input. Bar graph is now about 5 cm wide and it does respond to my talking into mic.
  5. I click on "Power" in Settings. I do nothing there.
  6. I return to Sound -> Input. Bar graph is now about 14 cm wide (!) and it does respond to my talking into mic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.