6

I have upgraded my system from 19.10 to 20.04, everything is working correctly except I cannot load hp-systray or any other parts of the program.

The problem I have is pyqt4 available in 20.04 I have been unable to locate it.

Terminal error below:

HP Linux Imaging and Printing System (ver. 3.20.2)
System Tray Status Service ver. 2.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: No module named 'PyQt4'
error: Unable to load Qt4/Qt5 support. Is it installed?

I also ran hp-check -r; output below:

rick@rick-M52BC-M32BC:~$ hp-check -r
Saving output in log file: /home/rick/hp-check.log

HP Linux Imaging and Printing System (ver. 3.20.2)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                    
2. Run-time check mode (-r or --run): Use this mode to determine if a distro    
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                      
3. Both compile- and run-time check mode (-b or --both) (Default): This mode    
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                    
a. EXTERNALDEP - External Dependencies                                          
b. GENERALDEP - General Dependencies (required both at compile and run time)    
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                    
PYEXT SCANCONF QUEUES PERMISSION                                                

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: ubuntu-20.04 version is not supported. Using ubuntu-19.10 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.4.0-26-generic #30-Ubuntu SMP Mon Apr 20 16:58:30 UTC 2020 GNU/Linux
 Host: rick-M52BC-M32BC
 Proc: 5.4.0-26-generic #30-Ubuntu SMP Mon Apr 20 16:58:30 UTC 2020 GNU/Linux
 Distribution: ubuntu 20.04
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.20.2
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for ubuntu distro  20.04 version 

Current contents of /etc/hp/hplip.conf file:

# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-3.20.2
html=/usr/share/doc/hplip-3.20.2
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.2
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no

Current contents of /var/lib/hp/hplip.state file:

Plugins are not installed. Could not access file: No such file or directory

Current contents of ~/.hplip/hplip.conf file:

[upgrade]
notify_upgrade = true
last_upgraded_time = 1582830956
pending_upgrade_time = 0
latest_available_version = 3.17.10

[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri = hpaio:/net/officejet_5200_series?ip=192.168.1.139&queue=false
printer_name = HP_OfficeJet_5200_series
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list = 

[fax]
voice_phone = 
email_address = 

[installation]
date_time = 04/27/20 18:23:19
version = 3.20.2


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.50            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.29          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.16         OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               -               OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.31'         OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.8             OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.8.2           OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.9           OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             3.8.2           OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               7.0.0           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.5.34          OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.3.0           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.20.2          OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.20.2          OK         -

----------------------
| Scan Configuration |
----------------------

 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.20.2          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.2          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

The device `hpaio:/usb/OfficeJet_5200_series?serial=TH9B5BD184` is a Hewlett-Packard OfficeJet_5200_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                      Model                   
  ------------------------------  ------------------------
  hp:/usb/OfficeJet_5200_series?  HP OfficeJet 5200 series
  serial=TH9B5BD184                                       

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------


HP_Fax_4
--------
Type: Fax
Device URI: hpfax:/usb/OfficeJet_5200_series?serial=TH9B5BD184
PPD: /etc/cups/ppd/HP_Fax_4.ppd
warning: Failed to read /etc/cups/ppd/HP_Fax_4.ppd ppd file
PPD Description: 
Printer status: printer HP_Fax_4 is idle.  enabled since Thu 27 Feb 2020 05:11:03 PM EST
Communication status: Good

HP_OfficeJet_5200_series
------------------------
Type: Unknown
Device URI: usb://HP/OfficeJet%205200%20series?serial=TH9B5BD184&interface=1
PPD: /etc/cups/ppd/HP_OfficeJet_5200_series.ppd
warning: Failed to read /etc/cups/ppd/HP_OfficeJet_5200_series.ppd ppd file
PPD Description: 
Printer status: printer HP_OfficeJet_5200_series is idle.  enabled since Mon 27 Apr 2020 05:22:39 PM EDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

HP_OfficeJet_5200_series_72D17F_3_
----------------------------------
Type: Unknown
Device URI: implicitclass://HP_OfficeJet_5200_series_72D17F_3_/
PPD: /etc/cups/ppd/HP_OfficeJet_5200_series_72D17F_3_.ppd
warning: Failed to read /etc/cups/ppd/HP_OfficeJet_5200_series_72D17F_3_.ppd ppd file
PPD Description: 
Printer status: printer HP_OfficeJet_5200_series_72D17F_3_ is idle.  enabled since Mon 27 Apr 2020 04:28:16 PM EDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

OfficeJet_5200_series_TH9B5BD184_
---------------------------------
Type: Unknown
Device URI: implicitclass://OfficeJet_5200_series_TH9B5BD184_/
PPD: /etc/cups/ppd/OfficeJet_5200_series_TH9B5BD184_.ppd
warning: Failed to read /etc/cups/ppd/OfficeJet_5200_series_TH9B5BD184_.ppd ppd file
PPD Description: 
Printer status: printer OfficeJet_5200_series_TH9B5BD184_ is idle.  enabled since Mon 27 Apr 2020 04:28:13 PM EDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

USB             None                           Required        -        -        OK       Node:'/dev/bus/usb/001/004' Perm:'  root  lp rw- rw- rw- rw- r--'

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible 
error: 'python3-pyqt4' package is missing/incompatible 
error: 'gtk2-engines-pixbuf' package is missing/incompatible 

Missing Optional Dependencies
-----------------------------
error: 'python3-dbus.mainloop.qt' package is missing/incompatible 

Total Errors: 3
Total Warnings: 3

  • 1
    Does this answer your question? How to install latest HPLIP on my Ubuntu to support my HP printer and/or scanner? - use sudo apt-get install hplip-gui . – N0rbert May 1 at 7:35
  • Ok, I followed the direction on the other post and still get an error now it is missing ui5. Also, the scanner only works as a network and the hp-fax does not seem to be working at all. I can get by with things this way, I just prefer to use the hp-toolbox and hp-fax and I would like the scanner to work via USB as well as network. I installed the 3.20.3 file on ubuntu 19.10 from the hp developer website as this Officejet-5252 was not supported in 3.19.x version. All worked fine til upgrade to 20.04 I think something from the previous install on 19.10 has something to do with it. Thanks you – Richard W. Seitz May 2 at 2:22
  • also in the hp-check.log, I get these errors at line 177-178 hp-check[612282]: info: :[31;01m error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'[0m hp-check[612282]: info: :[31;01m error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'[0m – Richard W. Seitz May 2 at 2:35
  • According to official HPLIP support page the HP OfficeJet 5200 is supported since 3.17.9. This means you can use deb-packaged version from Ubuntu 18.04 LTS and newer. Usage of binary installer may add mess to the system. Follow uninstallation part from my answer and then use sudo apt install hplip-gui. – N0rbert May 2 at 7:58
  • Ok, I have completely removed everything for the HPLIP devices. I cannot add modify or even add the printer with hplip-gui. when i tried to use hp-setup I got the following import error libhpipp.so.0. Thanks for any assistant – Richard W. Seitz May 3 at 0:25
4

You're probably going to have to completely reinstall HP printer support because you removed everything involving HPLIP. You probably will need to go to the HPLIP page and download, and install, the latest HPLIP. If you're able to do this, it will set up your printer and then give you the opportunity to install the correct plugin that will enable all of your printer's capabilities.

You might have avoided so much trouble if you had started by running the command N0rbert gave you, before you did anything else:

sudo apt install hplip-gui

(I know, you didn't know that then; I learned it the hard way, too. This works because HPLIP is already installed on Ubuntu, but not the GUI, which you need in order to get the plugin.)

Then run "HPLIP Toolbox" (I run it from the Dash, but you can run it from the command line, too). This will open a GUI which will give you the opportunity to install a required plugin. Many HP printers require this plugin to be installed in order to perform certain functions (such as scanning and faxing).

I have to do this every time I install a new version of Ubuntu (or reinstall) because my HP printer is one of those that requires a plugin, and it appears yours does, too. Plugins are not loaded by default, and unfortunately little information is provided anywhere about how to solve the problem.

| improve this answer | |
1

HPLIP supports Qt5 from 3.16.5 and above

To enable qt5 support

You need to install the following dependencies
    PyQt5
    python-qt5-dbus
Go to source of hplip. By default its in ~/Downloads.
Run the following commands
    ./configure --prefix=/usr --enable-qt5 --disable-qt4
    make
    "make install" as root user
| improve this answer | |
  • 1
    I notice one of the issue in installing PyQt5 on Ubuntu 20.04 as a part of HPLIP installation process was the installer was defaulting to python version 2.7. Once I set default to version 3.8, I could install HPLIP – Harish Jun 5 at 7:21
0

There seemed to be a problem with the version that was installed from the 20.04 repo, due to the fact I had 3.20.3 on the computer prior to the 20.04 upgrade, I installed 3.20.5 from the ubuntu 20.10 repositories. Now all seems to work ok with the exception of the device manager. When I click on hp-systray for the device manager it never loads the device manager. There is a gnome-shell extension for an alternate to hp-systray and I can call the device manager from there. So not working perfectly, but it is working. Here is the link for the alt hp app. https://extensions.gnome.org/extension/1339/hplip-menu/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.