3

After installing 20.04 (with Gnome desktop env), when I navigate through the GUI to my network share, all of the files appear as directories and I am unable to download/copy them to my local host. When I attempt to copy the folder (still in the UI), I received the following error message: Error message screenshot (Error while copying. There was an error reading the folder "filename.txt". No such file or directory)

When I attempt to cat a file after navigating to the share via CLI, I receive the following output: cat: filename.txt: Is a directory

When I attempt ls -la, all of the files show as directories.

When I attempt more filename.txt, the output is: filename.txt: directory

Prior to accessing my shared drive, I had to modify the smb.conf file to include "client min protocol = CORE" in order to even access the shared drive.

1
0

I too faced the same issue... and I solved this by :

The files shown as folders or directories will show user.DOSATTRIB on getfattr your_file_name command. for example,

:~/$ getfattr riscv.dts
# file: riscv.dts
user.DOSATTRIB

To remove that use setfattr -x user.DOSATTRIB your_file_name. for example,

:~/$ setfattr -x user.DOSATTRIB riscv.dts 
:~/$ getfattr riscv.dts 

This worked for me. for multiple files, use

find . -type f -exec setfattr -x user.DOSATTRIB "{}" \;

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.