Hi I recently killed my etc folder by running:

sudo chmod etc 417.

Due to sudo being in that folder it cannot be accesed now, so I have to change the permissions back to the correct ones using the recovery menu.

In recovery i tried this from recovery:

root@joeri-VirtualBox:/# chmod 755 etc
chmod: changing permissions of 'etc' : read-only file system
root@joeri-VirtualBox:/# cd etc
root@joeri-VirtualBox:/etc# ls -ld
drw-rw-rwx 139 root root 12288 2012-04-19 16:29

Even when I am root i cannot change it because it is read-only. How do I change these permissions?



  • This: sudo chmod etc 417. is not a valid instruction. It will end up with an error message invalid mode etc. Might be needed to include the exact command that was used. – Rinzwind Apr 19 '12 at 8:15

You have to remount the root file system with read/write permissions if you want to do changes in recovery mode mount -o remount,rw / I think is the command. Then you can modify the filesystem.

  • yes this fixed it! Thank you :) (twice) – Joeri Friederich Apr 19 '12 at 8:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.