8

I am trying to remove the popup notifications completely from Gnome. The notifications I mention are this:

enter image description here

I do not wish to see ANY notification at all from any app. Mainly because of 2 things:

  • Notification get in the way of me clicking a Browser tab
  • Notification stays way too long in there when I am in a hurry

Since I can't find a way of making the notification smaller (at least in an easy manner), moving it somewhere else, or even telling the option of Do Not disturb to stay fixed (when I reboot the PC it goes back to off). I am then looking for a way to completely disable this notifications altogether.

I have tried going to settings and disabling everything in there with no luck (and also because I can't do one app at a time and the idea of an option for DISABLE ALL is not there).

enter image description here

  • Hi PRATAP, yes, whatever removes the notifications from showing in a fairly easy way will solve my problem. – Luis Alvarado May 1 at 3:20
  • 2
    Hi PRATAP, save the last one as an answer and I will accept / upvote it. Thank you friend. That removes one very annoying problem for me. – Luis Alvarado May 1 at 3:42
7

Since some earlier versions of GNOME, One thing is unidentified why some of the gsettings keys are not persistent after a logout or reboot. For this case,

the workaround is to create a startup application preference to turn off this particular key like this. So that the key is turned off after a logout or reboot.

gsettings set org.gnome.desktop.notifications show-banners false

| improve this answer | |
  • 1
    Thank you for this, no clue why this isn't an out-of-the-box setting in Ubuntu, many many cheers +1 – SidOfc May 20 at 21:42
  • 1
    How to "create a startup application preference"? For example, it seems Startup Applications in Gnome Tweak Tools just shows a list of already installed apps, with no command lines. – Lexible Jun 11 at 0:38
  • This was a gnome-shell bug and it was fixed in Ubuntu 20.04 the very same day as you last edited your answer. – Gunnar Hjalmarsson Aug 14 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.