0

I tried to get rid of the timer, so grub immediated loads the OS.

This is the file that I edited with

sudo gedit /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

#GRUB_DEFAULT=0 *original code*
GRUB_DEFAULT=saved
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
2
  • Did you run sudo update-grub after editing the file? Dual boot? Ubuntu version? Please add information via edit to your question. – mook765 Apr 30 '20 at 20:39
  • 1
    Might be answered here: askubuntu.com/questions/148095/… – user573739 Apr 30 '20 at 22:19
0

I had the same issue before and wanted to add special background for Grub menu too and i found nice way to solve this issue , Just follow my steps :

1. Install grup customizer but How ? Just open your terminal using Ctrl+Alt+T , then type this commands in your terminal :

sudo add-apt-repository ppa:danielrichter2007/grub-customizer 
sudo apt-get update
sudo apt-get install grub-customizer

2. Press on Windows key , then type Grub.

enter image description here

3. Go to General settings, Then Boot default entry after and change timer as you want. Here, my timer is 1 seconds.

enter image description here

4. Click on Save , then Reboot your system and Congrats it's working.

Not Important :
1. If you want to change background , font size , color or anything related to appearance , then Go to Appearance settings, Here is my Grub :

enter image description here

2. Let's assume that you have installed Windows 10 and Ubuntu in your pc and want always to start Windows as Default , So go to List configuration

enter image description here

Hope that helps you, Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.