13

I tried to install Ubuntu 20.04 in my Dell G5 which has 2 drives. One with Windows 10 on it (256 GB) and another one with 1 TB capacity.

I shrunk the volume of 1 TB by 150 GB and tried to install there.

But Ubuntu installer didn't allow me as I got a dialog after the Keyboard setting said "Turn Off RST" with the message

This computer uses Intel RST (Rapid Storage Technology). You need to turn off RST before installing Ubuntu. For instructions, open this page: help.ubuntu.com/rst

If I make any changes in the BIOS setting, like changing the Intel controller from RAID to AHCI, Windows won't boot and goes into System Recovery.

I didn't have this issue when installing 18.04. While creating the partitions, you need to create a EFI partition with 200 - 500 MB with the usual steps and the installation will be completed succesfully.

On restarting, you will not be getting the GRUB but instead Ubuntu will boot by default. If you need to boot Windows, you will have to go to the BIOS and choose from the UEFI boot option each time.

Once 18.04 installation is complete, you can upgrade it to 20.04.

After upgrading I installed the KDE desktop and at the login screen I chose the "Ubuntu on Wayland" option.

After doing these 2 things, I lost the new features of 20.04 like the Ubuntu boot screen with Dell logo and the power off/log out blur effect screen. Not sure how to get that back.

  • See new documentation and discussion at discourse.ubuntu.com/t/… – user535733 Apr 30 at 18:55
  • I have the same problem. I just have one question. When you upgraded from 18.04 to 20.04 , apart from the missing things in GUI was there any major changes ? – Noah J. Standerson Aug 22 at 6:42
15

You've got a single HDD/SSD set up in RAID (RST) mode, and the Ubuntu installer won't recognize your HDD/SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot.

You don't need to reinstall Windows.

Below, you'll find two different ways to solve this problem. Some users found Choice #2 to be easier.

Important: Make sure to have a backup of your important Windows files!

Choice #1: Looking at this article will show you how to make the change without having to reinstall Windows.

Important: Some users reported to be completely unable to boot Windows after using Choice #1, without a full restore

  • Boot to Windows with your current SATA controller configuration
  • Open Device Manager
  • Expand Storage Controllers and identify the Intel SATA RAID Controller
  • View properties of the identified controller
  • On the Driver tab, click the Update driver… button
  • Browse my computer…, Let me pick…
  • Uncheck Show compatible hardware
  • Select Microsoft as manufacturer
  • Select Microsoft Storage Spaces Controller as model #
  • Accept that Windows cannot confirm that this driver is compatible
  • Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
  • Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

Choice #2: See here.

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows.  If so, use this method instead to get to the Command Prompt:
  • Click the Start Button and type cmd
  • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin)
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
| improve this answer | |
  • Thanks very much. I already tried the Choice #2. But my windows didn't boot after that it was going into System Recovery option. Then I reverted back the changes. I will try the Choice #1. I'm now used to live without the GRUB using the BIOS to get into Windows when needed. – SubinR Apr 30 at 20:50
  • Hi, as mentioned, if I change anything with the BIOS, the windows is going into System recovery and not booting. Now as I have already installed 20.04 as default OS and choose Windows from the BIOS Boot options when needed. I do not want to disturb it and lose my files. Thanks for checking. – SubinR May 2 at 3:07
  • I created an account just to thank you, nothing worked but this solution worked the first time!!! – Henry Le Berre Jun 15 at 23:06
  • @HenryLeBerre Thank you for the kind feedback! – heynnema Jun 16 at 3:15
  • 1
    @MarcosSaito No need to change registry keys via method #2. The link you provided is just another (more complicated) way to accomplish the same thing. – heynnema Aug 19 at 18:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.