15

After installing 20.04 on my desktop, my printer has stopped working.

Printer: HP Envy 5640, connected via USB. hplip installed. cups installed.

Any suggestions appreciated. Printer itself is OK as I have used it wirelessly to print from another PC on the network.

  • There are a lot of other people complaining about printer driver issues in 20.04 here as well – billynoah May 9 at 13:03
  • 1
    +1 upvote. Thank you. But honestly, what F*cking joke I have to p*ss about trying to get a f*cking printer to work, when it was fine on 18.04. This isn't good enough, no excuse, just because it's open source, and free, they've been doing this for years - 20 years because we're on 20.04 and printing ain't f*cking rocket science. – therobyouknow Jul 13 at 20:47
  • Not aimed at you. Grateful you raise the issue. Generally people have got better things to do in their lives than spend hours trying to get a printer to work. No excuse whatsoever. "But you learn things about the OS" - F*ck OFF - b*llocks. NO!!! I just want to f*cking print something, I'm in a hurry, I've got family etc I want to spend time with, keep fit etc. Intellectual masturbation about the innards of Linux and Ubuntu might suit some nerds, but the rest of us have got a LIFE. – therobyouknow Jul 13 at 21:11
  • I say to nerds: by now, if you want Linux to make the "big time" & dominate the desktop that you have gone on about for years - then - f*cking well make it work and do some f*cking testing and Quality Assurance! The rest of the software world has to and you're not exempt. P*llocks – therobyouknow Jul 13 at 21:14
  • Any printers brand known to work seamlessly across modern Ubuntu versions? The time spent on hacking my HP printer is simply not worth it .... – matanster Aug 27 at 10:44
10

Try sudo hp-setup -i. At least for USB. That finally helped me with a HP LaserJet Pro P1102w.

| improve this answer | |
  • that 'd explained a lot about why in my case the printer was printing after a 20.04 fresh install (was on & plugged during install) and this although many dependencies were missing for hplib, but not after deleting the printer & trying to reinstall it the normal way (not in admin mode) with all dependencies installed. will check tomorrow (pc not with me) but pretty sure that'll do it for me, thanks in advance ! – mikakun Jun 17 at 22:46
  • Can't believe this worked after so much other tinkering! it now says the printer queue is "driverless" but it just makes the printer do its job ... – matanster Aug 27 at 10:48
4

I have solved with the following steps, don't know if all are required, most likely only step 3 is the fix.

  1. Removed and reinstalled some packages:

    sudo apt-get update
    sudo apt-get remove hplip cups-filters cups hplip-data system-config-printer-udev
    sudo apt-get install build-essential tix groff dc axel cups
    sudo apt-get install cups-filters unp system-config-printer-gnome
    
  2. installed hplip from the hp's Developer Portal: https://developers.hp.com/hp-linux-imaging-and-printing/gethplip

    ver 3.20.5 claims to be compatible with 20.04 but in my case was not solving the issue:

  3. Finally, changing permissions to the ppd file:

    sudo chmod 644 /etc/cups/ppd/HP_ENVY_4520_series_XXXXXX_.ppd 
    

    where (i suppose) XXXXXX should be part of the serial number of the printer

Now the printer works fine. It took me several days to achieve this result, the printer was working perfectly on 19.10, so I am a little disappointed of this issue.

| improve this answer | |
  • this did not work for me,using the exact same printer and connected via usb.i hope this get fixed in the updates soon i have never had this problem in any version of ubuntu i started with 9.04 and is at 20.04 now. – trond hansen May 20 at 15:29
  • Worked perfectly on my Ubuntu 20.04.1 LTS machine connected wirelessly to an HP OfficeJet Pro 9010 series All in one printer. Thanks for your help on this! – user99513 Jul 24 at 12:04
  • worked also with my pixma, thanks – Sylvain Pineau Sep 9 at 15:08
4

If the printer was working for you with hplip before, just uninstall ippusbxd package:

sudo apt remove ippusbxd

The problem, at least in my case, was that ippusbxd was automatically creating a printer that was not working and was conflicting with my hplip printer.

| improve this answer | |
  • 1
    Thank-you very, very much. This was the cause of a 'Printer Busy' problem which plagued me for MONTHS after I installed Ubuntu 20.04.1 LTS by preventing correct wireless installation and hp-toolbox deployment. Did I say thank-you? – Bad Loser Aug 21 at 3:30
  • Running sudo hp-setup -i and changing the permissions of the ppd file didn't help (on their own), this did! – oulenz Oct 13 at 9:10
3
  1. install hplip gui as below

    sudo apt install hplip-gui
    
  2. from hplip gui go to actions and then install required plugin.

And this fixed it for fr model HP LasetJet 1018

| improve this answer | |
0

I tried to reinstall as per below link.

https://answers.launchpad.net/hplip/+question/690299

But then, I was getting communication error same as in below error.

"Device Communication error (5012)" - HP printer

But, the solution mentioned in above link, partially worked.

I reinstalled ubuntu 20.04 LTS and it was pretty quick and was able to install within 20 minutes.

While installation, I kept my printer switched on and it auto detected and then onwards it started working any issues.

I was able to print 1. Ubuntu Test Page. 2. I was able to print document on both sides.

Hope this may help others.

| improve this answer | |
0

I had same issue with a Brother printer. I uninstalled cups and reinstalled but it didn't solve the problem. Next, I uninstalled the printer using the printer settings GUI. I then added a new printer and it automatically found the driver and loaded. It works perfectly now. So I'd recommend just trying to remove it and reinstall the printer first using the GUI before doing anything in the terminal if you are not super techy, like me.

| improve this answer | |
0

text files wont print ubuntu 20.04

Sort of a solution:

1st Sun 28 Jun 2020 02:45:17 PM EDT <------------------/ trying cups install /---

open CUPS 2.3.1 http:

//localhost:631/

after install lp only prints 1st line of text file, and acts like job done ??????

-rwxr-xr-x 1 root 63080 Apr 10 09:12 /usr/lib/cups/filter/texttopdf <--------/ likely problem /---

-D [28/Jun/2020:14:46:02 -0400] [Job 59] PID 71266 (/usr/lib/cups/filter/texttopdf) crashed on signal 6.

[ jack @ s0n5-u20 scr-2 ~ ] $ echo "a" | CHARSET=utf-8 /usr/lib/cups/filter/texttopdf 1 user title 1 "PageSize=A4" > out.pdf Unsupported OTF font / glyf table texttopdf: fontembed/sfnt.c:651: otf_get_width: Assertion '0' failed. Aborted (core dumped)

print text files works ubuntu20.04 from gvim && konsole prt sc

enscript /tmp/le0203 [ 1 page * 1 copy ] sent to printer ----/ works /---

but has file location on header ??? not desireable.

enscript -B /tmp/le0203 no file location header !

print text files fails lp lpr

Using

enscript -B is a work around, <------/ my tmp solution /--

Weird Ubuntu 20.04 LTS not tested for lp and lpr use ???

jack

| improve this answer | |
0

Interesting question actually and quite by accident I found how to fix it. I have two computers, both experienced this problem after updating to 20.04 Kubuntu. The fix is easy and works every time. If you've only just installed the system, delete it and reinstall. This time do not select connect to the internet via wireless. Either plug in an ethernet cable or install without updates,both methods work.

Once the system is up and running go to systems and select KDE wallet, disable it. (doesn't every one do that to this useless annoying piece of sh** anyway :-) Now connect to the internet via WiFi.

Then go to printers and you should find your printer is now working!

I haven't investigated why this works but I'm assuming that if you connect to the internet during installation cups or somewhere else along the chain the printers wifi is assigned to root.

I know its going to be annoying to do this if you've spent an entire weekend tweeking the system. But if you've only just put it on and its still the basic interface it only takes twenty minutes or so to reinstall this method is simple and it works. I've done it on 4 computers now

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.