0

I realise that I could have easily waited for July 2020, but I upgraded to Ubuntu 20.04 today. I upgraded from 18.04 to 19.10 to 20.04.

Everything I've tried so far has worked fine except for AWS EB CLI. It worked fine on 18.04. Now, when I run eb deploy --staged I get the error, below.

Traceback (most recent call last): File "/home/me/.local/bin/eb", line 5, in from ebcli.core.ebcore import main ImportError: No module named ebcli.core.ebcore

Anyone got any idea how to fix this? Thanks.

1
  • To future users: please do NOT upgrade instances like AWS. The correct way is to create a system disk and a user disk. You connect system and user disk to create an instance. Upgrading to a higher version is done by creating a new system disk and then attach your user disk. Why? If the instance does not boot it is -dead- without a way to restore your system. If that includes data not on a backup it is gone. – Rinzwind Jul 12 '20 at 17:53
0

EDIT

The original answer was to uninstall Python 3.8 then install the utils for 3.7. DO NOT DO THIS. While this did allow me to use EB CLI, Ubuntu 20.04 needs Python 3.8 to run it's GUI. As a result, after restarting the machine I was unable to log back into the Ubuntu GUI.

A better way to do this would be to remove Python 3.7 and reinstall it...

sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt-get update
sudo apt-get install python3.7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.