4

I just installed Ubuntu 20.04 LTS on my Asus Table T100HA and the Webcam no longer works. I tried with Cheese and some other Programs on my Browser...

I need some Help. - Thanks!

6
  • Maybe a permissions issue, try sudo chmod 777 /dev/video.
    – dlin
    Commented Apr 30, 2020 at 14:09
  • sudo chmod 777 /dev/video*
    – dlin
    Commented Apr 30, 2020 at 14:43
  • Thanks - I got the exact same error message except with the asterisk included /dev/video*
    – Kevin B
    Commented Apr 30, 2020 at 14:46
  • No idea why. An option is to lower the resolution from "Preferences" in Cheese and restart it until you get it working, but this is a workaround and not a clear answer to your question.
    – dlin
    Commented Apr 30, 2020 at 14:52
  • Because it does not recognize a webcam, it does not give me an option to lower the resolution in Cheese.
    – Kevin B
    Commented Apr 30, 2020 at 16:02

3 Answers 3

1

I had the same problem on a desktop machine with a USB webcam. After 20.04 upgrade there's no webcam shown with lsusb and no files seen at /dev/video.

I fixed it by uninstalling Cheese:

sudo apt-get remove cheese

I installed guvcview:

sudo apt-get install guvcview

Then unplugged and replugged the USB webcam and ran guvcview.

Files have now appeared at /dev/video0 and /dev/video1. The webcam appears when I run lsusb and is functioning in Google Meet and Zoom.

3
  • I have also used external USB Webcams and have had no problems with them. (Logitech). This specific thread was about my embedded webcam in the ASUS Laptop. I believe that the problem is caused by a lack of Drivers in the distro of Linux. I have since installed Mint/Linux and the embedded webcam does not work there either. I am not alone, as there are scads of posts with users with the same problem. So, the solution is to buy a popular external webcam like a Logitech, and it will probably be recognized.
    – Kevin B
    Commented May 14, 2020 at 14:18
  • OK, but my webcam is an external Logitech USB, and it was working fine until I upgraded Ubuntu 19.10 to 20.04 So I think the problem was with the upgrade package.
    – davidhaynz
    Commented May 17, 2020 at 20:56
  • I have big issues with my Logitech Brio 4K on 20.04. I works from time to time, but mostly it just shows a black screen. I've also tried the apt version of cheese and also guvcview, no difference. Commented Dec 22, 2020 at 17:23
0

Uninstall the snap package. It Is borked, like many snap packages.

Install the normal version:

sudo apt install cheese
0

I checked the dmesg and found that the bitrate did not match. I attached the webcam to a USB 2.0 port and now it works perfectly.

At least it resolved the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .