3

Application (Firefox default browser) opening on 2nd workspace, while starting it from 1st workspace, after it has previously been opened by a program running in Wine (World of Tanks).

Also after booting the computer, Firefox keeps opening on the 2nd workspace, while the master password popup is on the 1st workspace where I opened it.

This gets extra confusing if the focus also goes to Firefox on the 2nd workspace, and you can not press any button on it like its frozen, due too the popup master password window on the other/1st workspace effectively being hidden from view, which needs to be exited first.

I am using four fixed workspaces, not on demand workspaces, although I assume that has nothing to do with it.

I am using Ubuntu 18.04 LTS 64bit.

In principle the solution to fix it temporarily is to open Firefox in Wine/WoT while it is running on the 1st user space, this 'fixes' it for opening FF on the 1st user space for one time it seems, how ever the same issue continues when trying to open FF in testing on different work spaces, it keeps popping back to the 2nd user space.

Also the opening on the 2nd user space seems to persist, after opening FF multiple times on the 1st user space.

  • Same thing happens to me. As confirmed by @ungutknut answer, this is Firefox specific. Firefox 78 remembers workspace at the time of closing, as part of "restore previous session" feature. I will propose to them to either remove restoring to same workspace, or add Linux specific config dialog checkbox. I totally need my tabs from previous sessions, but having to find the firefox window and moving to wanted workspace and having to remember to close it in correct workspace is... like not the ideal. I'm sure somebody already notified them, but I will check just in case. – Hatoru Hansou Jul 9 at 22:07
  • In the meanwhile, I propose this solution: askubuntu.com/questions/89946/… – Hatoru Hansou Jul 9 at 22:09
1

You should check if you have "restore previous session" enabled in Firefox? If so, you may be able to fix the problem by disabling it.

Having that enabled is at least is a way to trigger this behaviour on my Xubuntu 16.04, 18.04 and 20.04 installations. However I don't think this is intended.

| improve this answer | |
1

Disabling "restore previous session" regardless if that works or not is not useful to me as I keep near to a hundred tabs on stand by, I would rather live with the pain of the screen opening in another work space then disabling "restore previous session".

| improve this answer | |
  • Welcome to Ask Ubuntu! This is more of a comment than an answer. This doesn't answer the OP's question. Please read How to Answer. This is not a forum so please do not use answer button to state your opinion. – Sasuke Uchiha Jul 3 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.