0

When I run sudo apt-get install update && sudo apt-get install upgrade, I am getting these errors:

E: Unable to locate package update E: Unable to locate package upgrade

When I try to run sudo apt-get update && sudo apt-get upgrade, it looks it works but it still giving that kinda error :

Reading package lists... Done
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://downloads.mariadb.com/MariaDB/mariadb-10.4/repo/ubuntu bionic InRelease' doesn't support architecture 'i386'
E: The repository 'http://ppa.launchpad.net/paolorotolo/android-studio/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://downloads.mariadb.com/Tools/ubuntu bionic InRelease' doesn't support architecture 'i386'
1
  • That's not how these commands work. You update all your packages with sudo apt-get update && sudo apt-get upgrade. You install a single package with sudo apt-get install [package name]. Do man apt-get for more information. – Jos Apr 30 '20 at 11:57

Browse other questions tagged or ask your own question.