I've got a problem that I just can't figure out. Tried looking at other answers and working through the suggestions, but I still get the same error.

I have a ReadyNAS drive with CIFS enabled and shares set up. I can access the shares from Windows and from Ubuntu Desktop 8. There are no username/passwords needed to access the shares.

However, I am now setting up an Ubuntu server using 11.10 and when I try to mount the share using the following:

$ sudo mount -t cifs //nasdrive/media /mnt/ReadyNAS/media

I get the following error:

CIFS VFS: Send error in SessSetup = -13
CIFS VFS: cifs_mount failed w/return code = -13
mount error(13): Permission denied

I've tried adding "-o uid=1000,gid=1000,username=guest,password=" as well, with the same results. I am a bit of a newbie with command line Linux, so please be gentle with the jargon.

Thanks in advance for any help you can give!

  • Well, after a couple more hours of poking around, I found a post over at the readynas.com forums that said they basically create "hidden" accounts for each share. Changed my mount command to include -o user=media,password=,nogroup and, et viola, I'm all set. Furrfu. – Jim C Apr 19 '12 at 7:58
  • You should write your comment as an answer, because it answers your question. :) – Huygens Apr 19 '12 at 15:07

A post at the readynas.com forums led me to the answer to my own question (eventually!). Basically, ReadyNAS creates a user, starting at UID=1000 and with nogroup, for each share that you create. It never really tells you its doing this, but it does.

You can see/edit these using their FrontView web application, under Security > Account. For me, I simply used the following entry in FSTAB

//ReadyNAS/media /mnt/ReadyNAS/media -o user=media,password=,uid=1000,nogroup,ro,noserverino,iocharset=utf8 0 0

Note that the ReadyNAS CIFS implementation does not support server-side inode numbers, so to avoid a bunch of warning messages, be sure to include the noserverino option.

Also, this is a read-only mount to access a media library, so I didn't use password protection. If I was using a password, I would substitute a credentials file and use the credentials= option instead of user/password.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.