1

I'm trying to connect to a remote Windows 2012 R2 server with RDP using remmina. It connects fine, but it's really slow.

The mouse clicks and keyboard events take a lot of time to register, I can freely move the mouse around though, it's the clicks that take a lot of time.

It also lags a lot when I try to switch between windows on my remote desktop.

I cannot really change the settings on the remote machine, all I can do is play around with my RDP client.

I'll attach my terminal output and my connection string below.

$ remmina --connect group_rdp_dev-machine_192-168-0-78.remmina

Remmina plugin glibsecret (type=Secret) has registered but not yet initialized/activated. Initialization order is 2000.

** (process:21462): CRITICAL **: 10:47:00.608: secret_service_load_collections_sync: assertion 'paths != NULL' failed
[glibsecret] unable to get secret service: Unknown error.

group_rdp_dev-machine_192-168-0-78.remmina

[remmina]
gateway_domain=
disableclipboard=0
serialpath=
disable_fastpath=0
disablepasswordstoring=0
shareserial=0
password=<password_digest>
parallelname=
gwtransp=http
gateway_password=
sharesmartcard=0
old-license=0
ssh_tunnel_loopback=0
shareprinter=0
resolution_height=0
group=
enable-autostart=0
ssh_tunnel_enabled=0
smartcardname=
domain=<domain>
serialname=
ssh_tunnel_auth=2
ssh_tunnel_server=
loadbalanceinfo=
ignore-tls-errors=1
clientname=
sound=off
resolution_mode=1
ssh_tunnel_password=
protocol=RDP
relax-order-checks=0
name=Dev Machine
clientbuild=
security=
gateway_username=
postcommand=
quality=0
username=<username>
gateway_usage=0
resolution_width=0
ssh_tunnel_privatekey=
console=0
microphone=0
ssh_tunnel_passphrase=
gateway_server=
disableautoreconnect=0
ssh_tunnel_username=
glyph-cache=0
serialpermissive=0
execpath=
multitransport=0
cert_ignore=0
exec=
parallelpath=
printer_overrides=
serialdriver=
precommand=
server=<server_ip>
useproxyenv=0
colordepth=66
shareparallel=0
sharefolder=
window_maximize=1
viewmode=1

OS Details

$ lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 19.04
Release:    19.04
Codename:   disco

1
0

I had this same issue on one out of two Ubuntu PCs, which are trying to RDP into a 3rd Linux PC with Lubuntu running. In fact even the UI for Remmina was quite slow when trying to click on the toolbar in RDP.

Due to the fact that only one of my Ubuntu PCs Remmina client was always slow when connecting I figured its nothing wrong with the Lubuntu PC I'm trying to connect to.

In the end I EXACTLY duplicated the connection settings from the smoothly working Remmina client into the one that was super-slow and suddenly its working smoothly!

Turns out the only difference in settings between the two clients was the SLOW client had the Resolution setting set to Custom 1024x768 and the smoothly working one had Use initial window size. It is very strange that this was the issue but it worked for me.

Try setting Resolution to Use initial window size for the connection in the Remmina GUI connection settings

OR in your .remmina settings file: resolution_mode=2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.