0

RootsMagic 7.6.3 is a genealogy software package and worked well using Wine 4.0 on Ubuntu 19.10 (in fact RootsMagic has been working well on Ubuntu 15.04 to 19.10 using the distribution package for Wine). Something changed in the upgrading to Wine 5.0 during the dist-upgrade from Ubuntu 19.10 to Ubuntu 20.04. This change causes no problems with invoking RootsMagic, however the adding fact feature (e.g. adding census information for a person) leaves Ubuntu 20.04 hung.

Does anyone have ideas bout how to resolve this? I have tried sudo add-apt-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main' and sudo apt-get install wine --upgrade and sudo dpkg --add-architecture i386 and that made no difference. Reinstalling wine 4.0.4 resolved the issue, but affects other software accessed using Wine. I also tried sudo apt install playonlinux and the does not appear to work. Mismatch between python 2.7.18rc1 and wx containers compatible with 2.8.

Tried wine-5.7 today using (https://wiki.winehq.org/Ubuntu) instructions to install Development branch. Issue resolved.

3
  • 1
    Does this answer your question? How does one install PlayOnLinux?
    – N0rbert
    Apr 30, 2020 at 8:08
  • No. I am very satisfied with wine 4.0.4 for RootsMagic 7. I would have liked to use wine's current version 5.0.3 or even the development version 5.7 with Ubuntu 20.04 and would have but for this inexplicable issue. To install RootsMagic all I had to do was wine RM7Setup.exe, which is fairly straight forward. I suspect the issues is because "Ubuntu's implementation of Multiarch is still incomplete." (wiki.winehq.org/Ubuntu)
    – Sildeag
    Apr 30, 2020 at 16:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.