0

I have a Raspberry 4 / 4G running Ubuntu, it has a 7” touch Screen connected with a ribbon cable. When Plug a TV or other Monitor into the HDMI port I only get sound. As soon get no options in the settings for the second monitor.

This what I get when I run xrandr with the second monitor plunged in

ubuntu@brad-pi:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 480, current 800 x 480, maximum 800 x 480
default connected primary 800x480+0+0 0mm x 0mm
   800x480        0.00* 

any help or point in the right direction would appreciated

1
  • There are 2 micro hdmi ports on the Raspi 4. Hook each one up to a moniter
    – ldias
    Commented May 2, 2020 at 14:37

1 Answer 1

0

I have the same configuration as you. (Ubuntu on a raspberry pi with 7" display with a second monitor connected via HDMI cable). The following worked for me.

sudo nano /boot/fireware/usercfg.txt

After the file is open

# Definitely required
dtoverlay=vc4-fkms-v3d

# If one of the monitors have dark border
disable_overscan=1

# Not sure what it does. Might not be required.
max_framebuffers=2

Save and exit. Install the following

sudo apt install xfce4-settings

Reboot

sudo reboot

After login to check the displays

xfce4-display-settings &

For me, this was displaying two monitors side by side (one huge and another small). To get the name of the displays:

xrandr --current

If it is displaying two different monitors

xrandr --output <projector> --same-as <desktop>

where in my case was HDMI-1 and was DSI-1. To switch off the (DSI-1) monitor

xrandr --output HDMI-1 && xrandr --output DSI-1 --off

This will switch off the DSI-1 monitor.

My references: Ref1, Ref2, Ref3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .