4

I am using DELL Latitude 5495 with AMD ryzen 5 pro . I accidently updated from 18.04 LTS to Ubuntu Focal Fossa 20.04 (development branch) instead of LTS.

I have been facing a lot of lag/freeze issues very frequently. Pixelation of graphics is noticed and Cursor and keys freezes for a few seconds mostly while using a browser/application. Seems to get better temporarily with reboots.

How can I resolve these issues or shift to the LTS version of 20.04/rolldown to 18.04 LTS to avoid them without losing data? (I am fairly new to linux)

It is similar to Random temporary screen lags since upgrade to 18.04

The results of sudo lspci | grep VGA && sudo lshw -c video | grep configuration && glxinfo | grep -i vendor are:

04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev d1)
04:00.7 Non-VGA unclassified device: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/Renoir Non-Sensor Fusion Hub KMDF driver
       configuration: driver=amdgpu latency=0
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: X.Org (0x1002)
OpenGL vendor string: X.Org

edit 2: In my case, It wasn't an issue with the drivers or swap, I downgraded the linux kernel from 5.4.0.12 to 5.3.0.28... works like charm!

  • 20.04 is no longer a dev release, so it is unlikely you need to do anything other then install updates. – mikewhatever Apr 29 at 22:38
  • 1
    @mikewhatever Trying to run the software updater within Ubuntu prominently displays that whatever it's installing is the development release. I think someone forgot to flip a switch somewhere. – GalacticCowboy Apr 29 at 23:01
  • @KaranjotSingh Please do not mark your question as "solved". Add an answer below and mark the answer as accepted by clicking on the gray tick mark on the left side of the answer. This is how this site works. Thank you – Raffa May 2 at 19:52
  • 1
    @Raffa Thanks, much appreciated! – Karanjot Singh May 3 at 8:21
  • I just want to say that my problem was the 4K monitor with GNOME. I solved switching to KDE. – Mich. Gio. Oct 8 at 17:52
1

In my case, It wasn't an issue with the drivers or swap, I downgraded the Linux kernel from 5.4.0.28 to 5.3.0.28 by selecting advanced Ubuntu options in grub,booting into old kernel and removing the problematic kernel (here 5.4.0.28) by:

sudo apt-get purge linux-image-unsigned-5.4.0-28-generic

which gives error:

rmdir: failed to remove '/lib/modules/5.4.0-28-generic': Directory not empty.

manually remove the directory by:

sudo rm -rf /lib/modules/5.4.0-28-generic

Then update grub:

sudo update-grub2

... works like charm!

| improve this answer | |
0

I know your problem has been solved. I too faced this problem after upgrading to Ubuntu 20.04 from 19.10 and I tried downgrading the kernel(to ```5.2.21``), updating nvidia drivers and changing swapiness but these didn't work.

In the end, I tried disabling running applications. I found that System Load Indicator was causing the lags.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.