Trying to download an engineering program, Salome-9.4.0, of size 2 GB. The download stopped right about when it was 99 or 100% done as it "ran out of disk space". It was downloading to my Desktop on my Xubuntu 18.04 system. Xubuntu uses the XFCE desktop rather than the older Gnome.

My laptop has 2 drives and is dual boot (Win-10 + Xubuntu 18.04). The smaller SSHD boot drive appears to have used 64 of 128 GB. The 2 GB data drive (also an SDD) should be < 25% full. Maybe this is 2 TB? It's a big modern drive.

df returns the following info:

jim@Zenoba-Lin:~$ df
Filesystem     1K-blocks     Used Available Use% Mounted on
udev             6084632        0   6084632   0% /dev
tmpfs            1221408     1484   1219924   1% /run
/dev/sda6       15198088 14190588    215744  99% /
tmpfs            6107028   372608   5734420   7% /dev/shm
tmpfs               5120        4      5116   1% /run/lock
tmpfs            6107028        0   6107028   0% /sys/fs/cgroup
/dev/loop0         56320    56320         0 100% /snap/core18/1705
/dev/loop1         56064    56064         0 100% /snap/core18/1668
/dev/loop2         27776    27776         0 100% /snap/snapd/6953
/dev/loop3         63616    63616         0 100% /snap/gtk-common-themes/1506
/dev/loop4         56192    56192         0 100% /snap/gtk-common-themes/1502
/dev/loop5          7936     7936         0 100% /snap/gedit/371
/dev/loop6         27776    27776         0 100% /snap/snapd/7264
/dev/loop7         18432    18432         0 100% /snap/gedit/537
/dev/loop8        164096   164096         0 100% /snap/gnome-3-28-1804/116
tmpfs            1221404       24   1221380   1% /run/user/1000
/dev/sda1       95506172 75104356  20401816  79% /media/jim/SSHD_boot

Does this mean my Ubuntu installation is filled up? Is there a way to adjust partitions so as to get more space? Eventually I may buy a bigger boot flash drive than the 128 GB.

  • Yes I note the /dev/sda6 is 99% full. I've installed Baobab and can get nice pictures of my hard drive but am not sure what they mean in terms of free space. It is also possible to upgrade the flash boot SSDD but is a real pain. I may do that down the road tho. – Nicholas Bourbaki Apr 29 '20 at 18:28
  • Thanks very much Mark. I think there are some videos / utilities on moving partitions so as to allocate more disk space to Linux. They always tell you you need this much. I double or triple that, then still run out of space soon after installation. – Nicholas Bourbaki Apr 29 '20 at 18:55
  • If my calculation is correct, you only allotted 7 or 8GB to the / partition. This might be enough if you had a separate home partition for storing files on but you don't. It is good practice to give the / partition 30+ GB, the system will eat about 5GB and needs some free space to operate, the rest can be used as storage for documents or downloads etc.. – Mark Kirby Apr 29 '20 at 18:59
  • Actually I intended to add a data partition. The / was only supposed to be for the installation of Xubuntu 18.04 OS files. At least that's what the instructions said. Apparently the ext4 partition which was supposed to hold all the data was never made? Maybe it was made but never connected to the / partition. Can I create some ext4 space on my secondary data drive and add it to the / partition? – Nicholas Bourbaki Apr 29 '20 at 20:47
  • The Samsung 860 secondary drive I added is only 1TB apparently, a 2 TB is still very expensive. Of this the Baobab shows 818.8 GB total (~90% free space). Is that loss from 1TB to 0.818 due to formattig or is there 100 GB somewhere I intended for ext4 Linux space? – Nicholas Bourbaki Apr 29 '20 at 21:00

Finally it seems to have worked. I basically followed the article Partition Home Moving

I was able to create an ext4 partition on my 2nd harddrive ~180 Gb of space and use it for my /home directory and presumably programs will use that space. The Xubuntu OS will continue to use the original 15 Gb ext4 partition on the boot drive.

It was not immediately apparent that it worked from my graphical Desktop info. The solution Question & answers are here: Failed to move /home directory to a new partition?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.