My brother has Windows xp on his laptop and I have Ubuntu 10.10 installed and samba is also installed on mine and when I connect my laptop with a desktop running Ubuntu, I am able to see and access the shared files. So sharing works fine between two Ubuntu computers.

My brother's and my laptops are connected through the cross cable for me to access the shared folder on my Ubuntu laptop from his xp shared folder.

I connect both laptops and then ping, ping gives perfect reply and I can see his computer name in the Places > Network

When I try to open his shared folder from there I get and option to enter the password I enter the password but the password prompt pops up again. I tried to enter his password and mine password also but each time I enter the password nothing happens but the password prompt pops again without any error report.



The password prompt was actually asking for the samba user password which I had not set then, I think this is not my fault completely cause it the password prompt should have shown and error that enter samba user password not account password.

Just enter this commad to give a password to the samba account

sudo smbpasswd USERNAME -a

where USERNAME is your username and then enter and provide with a password for samba user.

  • I want to tell the moderators that I added the "solved" title because I didn't want anybody else to be bothered about a solved question and I added the answer underneath the question because once I was asked to do so in case I sort out the problem myself. And I cant mark my own answer solved before 2 days but still I am being asked to mark it as solved. – Gaurav Butola Nov 10 '10 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.