3

I am trying to install Packet Tracer 7.3 (latest version) on Ubuntu 20.04 but do not succeed to so so because of two dependencies which are not installable ("libdouble-conversion1" and "qt-at-spi").

However I successfully installed the previous version (7.2.2) which was available in an Ubuntu installer format (.run file) but I nothing happens when I run it from my gnome desktop.

I am quite a newbie in Linux so I appologies if answers are obvious...

Thanks in advance ;-)

Denis

4

Had the same issue and fixed it this way:

After installing version 7.2.2 you'll have a /opt/pt folder (if default location was chosen)

In that folder there's a packettracer script that points to

/opt/pt/bin/PacketTracer7

Running that script I got this error:

./PacketTracer7 
./PacketTracer7: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

So I installed that library using this commands (taken from: https://www.linuxuprising.com/2018/05/fix-libpng12-0-missing-in-ubuntu-1804.html)

sudo add-apt-repository ppa:linuxuprising/libpng12
sudo apt update
sudo apt install libpng12-0

The installation was succesfull and now Packet Tracer run OK.

Hope it helps

2
  • 1
    Hello Oscar, thanks for your help ! By the way I found useful Packet Tracker 7.3 installation instructions here : askubuntu.com/questions/1206794/… (I should had looked deeper before posting). Thanks anyway ! – Denis Apr 30 '20 at 16:20
  • Hi Denis, great, I'll check that post to see if I can update the version. – Oscar Adolfo Martinez Russi May 1 '20 at 1:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.