10

After upgrade from Kubuntu 19.10 to 20.04 Dolphin opens new folders in a tab instead of a new window.

How to completely disable tabs in Dolphin?
How to open folders (e.g. by click from desktop) in a new window instead of a new tab?

Thanks and sorry for my czenglish :)

3
  • 2
    Maybe check/uncheck Configure Dolphin > Startup > Open new folders in tabs?
    – DK Bose
    Apr 29, 2020 at 9:33
  • :D Thank you! I don't understand why I didn't see it :) Apr 29, 2020 at 9:53
  • You're welcome. You can go ahead and post that as the answer yourself.
    – DK Bose
    Apr 29, 2020 at 10:21

2 Answers 2

5

You can go under File Associations and set your favorite application for folder, when choosing Dolphin, you can go in Application properties and add the command line parameter --new-window before the %u

thinking about this, you could have both configure, and have the option to right click -> open with -> dolphin new tab/window

see attached screenshot

file associations settings

1
  • Per comment by DK Bose - "Maybe check/uncheck Configure Dolphin > Startup > Open new folders in tabs? " - this worked for me. Did not need to change the application properties. Dolphin has configuration for this option. Dec 27, 2021 at 18:39
4

DK Bose gave the correct answer in a comment, but no one has created an answer so far, which is why this question cannot be marked as answered. So I'll just do it.

If you want folders open in new windows instead of tabs (for example, when you open a folder from a terminal or other application) you can configure this in Dolphin preferences by unchecking Configure Dolphin > Startup > Open new folders in tabs option.

This won't disable tabs in Dolphin completely (in fact, I don't believe it's possible at all), so you can still open a new tab using an option in the menu or the New Tab button.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .