31
    Wine Installer v1.0

Warning !! wine binary (still) found, which may indicate
a (conflicting) previous installation.
You might want to abort and uninstall Wine first.
(If you previously tried to install from source manually, 
run 'make uninstall' from the wine root directory)

We need to install Wine as the root user. Do you want us to build Wine,
'su root' and install Wine?  Enter 'no' to build Wine without installing:
(yes/no) yes
Running configure...

checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for cpp... cpp
checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

Configure failed, aborting install.

How do I fix this problem?

29

I guess you use Ubuntu 12.04 x64 which now supports multi-architecture. In other words, on a 64-bit system you can build only Wine-x64 version. Building 32-bit Wine on Ubuntu 12.04 x64 seems too buggy as for now.

So just run this command:

./configure --enable-win64
  • 6
    Doesn't that build wine64 instead of wine? I can't run windows 32-bit programs with wine64. – Gauthier Jul 29 '13 at 12:23
  • 1
    nowadays wine requires flex and bison so sudo apt install flex bison first but yes this is the best answer. – tatsu Mar 10 '18 at 11:54
19

As per: https://stackoverflow.com/a/17748092/108802

You need to install the gcc-multilibs.

sudo apt-get install gcc-multilib g++-multilib

Then [...] specifyiong a 32-bit host and passing 32-bit compilation flags:

./configure --host=i686-linux-gnu "CFLAGS=-m32" "CXXFLAGS=-m32" "LDFLAGS=-m32"
  • In my case, this still resulted in a slew of unmet 32-bit dependencies that apt refused to install. I think it would be less of a headache to install virtual Linux machine for compiling 32-bit stuff. – Hubro Jun 19 '14 at 20:50
  • 1
    This is a better answer, since sometimes wine64 is unable to run 32-bit applications – Brandon Kuczenski Nov 21 '16 at 6:06
3

try installing the 32 bits dependencies

sudo apt-get install ia32-libs
sudo apt-get install gcc-multilib g++-multilib
sudo apt-get install xserver-xorg-dev:i386 libfreetype6-dev:i386
0

I'm able to do installition linux "RedHat 6.4" after installing some of the packages like gcc,gcc-c++,flex,bison etc.

with below run on prompt:

./configure --enable-win64 --without-freetype

make

wine notepad++.exe
  • 5
    and, does that work in Ubuntu? – Braiam Oct 3 '13 at 15:12
0

Ubuntu 18.04.1 having 64 bit

  • sudo install flex
  • sudo install bison
  • ./configure --enable-win64 --without-freetype,
  • make

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.