3

Microphone is not working on my desktop. What I have tried to:

  1. Reinstalled alsa-base pavucontrol pulseaudio. This changed nothing

sudo apt removeauto --purge alsa-base pavucontrol pulseaudio

sudo reboot

sudo apt install alsa-base pavucontrol pulseaudio

  1. Removed pavucontrol and pulse audio. And then micro started working, but no sound control and started to appear error Error loading QML file: file:///home/noah/.local/share/plasma/plasmoids/org.kde.plasma.audiodeviceswitcher/contents/ui/main.qml:29:1: module "org.kde.plasma.private.volume" is not installed

  2. Installed pavucontrol and pulseaudio, rebooted and then sound control came back, error disappeared, but micro stopped working again

4
  • I have an external microphone that stopped working with Ubuntu 20.04 but worked fine before. I'm sure it's a bug. Please mention me if you found a corresponding bug issue. ;) May 19 '20 at 5:59
  • @alexanderadam, have you tried my solution bellow? May 19 '20 at 16:25
  • Yes I did. This wasn't my problem though. In my case the microphone isn't always recognized since 20.04. May 20 '20 at 6:59
  • In my case I solved the problem with this answer. Jul 13 '20 at 12:43
1

Ok, so this is what fixed this issue for me

  1. Run command pavucontrol or just open pavu volume control in apps
  2. Go to 'Input Devices'
  3. Scroll down to 'Built-in Audio Analog Stereo'
  4. Click on lock icon
  5. Set 'Front Right' slider to zero
  6. Adjust 'Front Left' so you get clean sound

I think that you may try to go with 'Front Left' to zero instead, based on you mic.

Not the answer you're looking for? Browse other questions tagged or ask your own question.