3

I did a clean install of 20.04. In files I can see my NAS but can't access it as it does not give the password dialog box.

There are other posts saying to modify the smb.conf file to make this work but I don't seem to have this file with a fresh install. Is there a way to fix this or is this version of Ubuntu basically useless to anyone with an older but perfectly functional NAS?

  • What is SMB protocol version on NAS? With SMBv1 there are too many problems with Ubuntu 20.04. It’s deprecated protocol. samba.org/samba/history/samba-4.11.0.html – adasiko Apr 29 at 4:30
  • The NAS is v1 and I know it is outdated and that there are security issues. That doesn't change the fact that you should have an option to access it. Even Windows gives you the option. I have no issue modifying the SMB.conf file like most posts about this are saying but with a clean install that file doesn't exist. Is there any other way of enabling v1? – George Apr 29 at 10:56
  • For me, it is now solved after today's (may 21) Ubuntu upgrade to 2:4.11.6+dfsg-0ubuntu1.2. With full samba installed and "client min protocol = NT1" add to smb.conf I can mount the NAS share and the objects (avi, jpg, etc.) are seen and treated properly as objects not as folders. I haven't tried with just samba-common installed. – ross minet May 21 at 14:44
  • I found this article very helpful in resolving my issues with setting up SMB Server in Ubuntu 20.04 lts with a static IP, and mapping the shared drive in Windows 10 Enterprise: linuxconfig.org/… The main issues that resolved the connection were with turning on the MS Services that were inactive by default. – Wellwisher1348 Jul 9 at 13:20
2

One way to resolve this issue in Samba:

Edit /etc/samba/smb.conf

That file will be added when you install either the samba package or the smbclient package. If you don't want to install samba install smbclient:

sudo apt install smbclient

Then edit /etc/samba/smb.conf and right under the workgroup = WORKGROUP line add this one:

client min protocol = NT1

Another way - and one I prefer myself - is a cifs mount.

| improve this answer | |
  • For many people with router from a ISP, this solution did not work until today's (may 21) Ubuntu upgrade to samba 2:4.11.6+dfsg-0ubuntu1.2. With the previous samba version all the objects (avi, jpg, etc.) in the NAS share were seen and treated as folders. – ross minet May 21 at 14:48
0

There's a problem with 20.04 accessing NAS share. You can check if you have an old Ubuntu 18-19 live dvd: it can access NAS share out of the box without tweaking anything.

In 18-19 and 20.04, only samba.lib, cifs.lib, nfs.lib are installed. It's sufficient in 18-19 but it does not work for NAS share in 20.04. So the solutions commonly found (full cifs, full samba, full nfs) all miss the point: you did not need to do any tweaking in 18-19.

Smb.conf is installed if you install FULL samba for directory sharing (other than NAS) for instance and it works well in 20.04. In Gnome 3.36, if you share a folder, it installs full samba automaticaly and it works out of the box in 20.04. But you won't be able to acccess NAS shares or if you can the objects (avi, jpg, text etc.) are all seen as folders. This behaviour is a known bug suppposedly recently solved. (Page bottom) https://launchpad.net/~sergiodj/+archive/ubuntu/samba-bug1872476-v2

| improve this answer | |
0

I added these two lines to smb.conf in the [global] section and that fixed it for me on Xubuntu 20.04.

client min protocol = NT1 

server min protocol = NT1

More details are given here: Broken samba shares

| improve this answer | |
  • Unfortunately, it does not work on Gnome 3.36 Ubuntu 20.30. You can mount and access the NAS share but every object (avi, jpg etc.) is seen as a folder! – ross minet May 13 at 22:24
0

add
client min protocol = NT1 into /etc/samba/smb.conf following [global]part

sudo add-apt-repository ppa:sergiodj/samba-bug1872476-v2

sudo apt update

sudo apt upgrade

| improve this answer | |
  • Please explain, what that add-apt... command does and why it helps. – guntbert May 16 at 22:01
  • This comment refers to a discussion on a bug. If you add client min protocol = NT1 to smb.conf after a full samba install, you may access the NAS share but every objet is seen as a folder. So it's useless. In the discussion, someone is mentionning a PPA (a repository) solving the problem, for the sake of discussion. They say the solution is coming. Adding PPA's is not a great idea for security reasons. It's a widespread bug waiting for a solution. – ross minet May 17 at 17:18
0

i've got a simple solution for newbies. step 1: instal smb4k with the standard software installer from 20.04. Step2 run smb4k several times and then shut it completely down. You now have a etc/samba directory with a smbconf file. step 3 Go to terminal and give in line "sudo nautilus" Your file browser starts up with root authority. Navigate to etc/samba and open smbconf file. You can now ad the line"client min protocol" to the global chapter of the smbconf file. I prefer it as the last line of the chapter. safe the file. Step 5. run smb4k again so smb is restarted. now you can open your old fashioned NAS. It works for mee Good luck

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.