1

I upgraded to Ubuntu 20.04 today, and after this upgrade tracker-miner-fs seems to crash and restart contiguously; pegging my CPU at 100% until I manually kill the process.

The error I'm getting in /var/log/syslog is:

Apr 28 22:23:01 evertbook5 tracker-miner-f[31182]: Could not find parent node for URI:'file:///home/evert/Music/unsorted/iTunes%20Music/Giorgio%20Moroder/E=MC2'
Apr 28 22:23:01 evertbook5 tracker-miner-f[31182]: NOTE: URI theme may be outside scheme expected, for example, expecting 'file://' when given 'http://' prefix.
Apr 28 22:23:01 evertbook5 tracker-miner-f[31182]: tracker_file_system_set_property: assertion 'file != NULL' failed
Apr 28 22:23:01 evertbook5 tracker-miner-f[31182]: tracker_file_system_set_property: assertion 'file != NULL' failed
Apr 28 22:23:01 evertbook5 tracker-miner-f[31182]: Could not find parent node for URI:'file:///home/evert/Music/unsorted/iTunes%20Music/Giorgio%20Moroder/E=MC2/08%20Evolution.mp3'
Apr 28 22:23:01 evertbook5 tracker-miner-f[31182]: NOTE: URI theme may be outside scheme expected, for example, expecting 'file://' when given 'http://' prefix.
Apr 28 22:23:01 evertbook5 tracker-miner-f[31182]: tracker_file_system_set_property: assertion 'file != NULL' failed
Apr 28 22:23:01 evertbook5 tracker-miner-f[31182]: tracker_file_system_set_property: assertion 'file != NULL' failed
Apr 28 22:23:02 evertbook5 tracker-miner-fs[31182]: **
Apr 28 22:23:02 evertbook5 tracker-miner-fs[31182]: Tracker:ERROR:../src/libtracker-miner/tracker-file-system.c:259:file_tree_lookup: assertion failed: (ptr[0] == '/')
Apr 28 22:23:02 evertbook5 tracker-miner-fs[31182]: Bail out! Tracker:ERROR:../src/libtracker-miner/tracker-file-system.c:259:file_tree_lookup: assertion failed: (ptr[0] == '/')
Apr 28 22:23:02 evertbook5 systemd[2738]: tracker-miner-fs.service: Main process exited, code=dumped, status=6/ABRT
Apr 28 22:23:02 evertbook5 systemd[2738]: tracker-miner-fs.service: Failed with result 'core-dump'.
Apr 28 22:23:02 evertbook5 systemd[2738]: tracker-miner-fs.service: Scheduled restart job, restart counter is at 45.

There's isntructions to permanently stop this process, but I would rather to see it work.

6

Removing the tracker database seems to have done the trick:

rm -r ~/.cache/tracker
  • what is tracker miner? was consuming 100% of my cpu usage 10' ago – Minsky Nov 26 '20 at 9:10
2

This solution worked for me...

So how to completely disable Tracker, so it no longer indexes any files, and stop having any Tracker process running in the background? You can mask the Tracker systemd services to completely disable it for your current user using this command:

$ systemctl --user mask tracker-store.service tracker-miner-fs.service tracker-miner-rss.service tracker-extract.service tracker-miner-apps.service tracker-writeback.service

After this, reset Tracker:

$ tracker reset --hard

And reboot.

Source: https://www.linuxuprising.com/2019/07/how-to-completely-disable-tracker.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.