0

Since a fresh installation of ubuntu 20.04 this weekend from the very beginning of account use I got a warning about termination of IBus process from a unknown problem, I believe the process was killed. At least from ps in terminal I know processes: ibus-memconf, ibus-ui-gtk3, dbus-daemon, ibus-extension-, ibus-x11, ibus-porta are active now. I finished the installation and the ubuntu now has two problems, don't complete the shutdown and has the keyboard misconfigured. My concern here is the keyboard to be set up to key-mapping pt_BR in Brazil known as ABNT2.

I have already tryed

sudo update-locale LANG=pt_BR.UTF-8 LC_MESSAGES=POSIX

and

sudo apt-get remove ibus
sudo apt-get install ibus

and

sudo dpkg-reconfigure keyboard-configuration

for generic 104-key PC portuguese (Brazil) no dead keys

from

sudo nano /etc/locale.gen

I have

`# many locales listed here mine uncommented
# pap_CW UTF-8

# pl_PL ISO-8859-2

# pl_PL.UTF-8 UTF-8

# ps_AF UTF-8

# pt_BR ISO-8859-1

pt_BR.UTF-8 UTF-8

# pt_PT ISO-8859-1

# pt_PT.UTF-8 UTF-8

# pt_PT@euro ISO-8859-15

apparently the recommended. I tryed also

sudo update-locale LANG=pt_BR.UTF-8 LC_MESSAGES=POSIX

tryed

sudo setxkbmap -model abnt2 -layout br

after each change I did

sudo locale-gen

logged of, logged in... afterall I still have my keyboard accentuation not well configured. It recognizes the ç key for example (is a qwerty type) but I cant use ~ ' ` the correct setup holds the ' when typed for next letter say o to accentuate correctly as ó... I instead get 'o

More info, if helps:

walter@walter-POS-EIBTDB:~$ cat /etc/default/keyboard
XKBLAYOUT=br
BACKSPACE=guess

Any further light to solve my problem is welcome.

  • 1
    So IBus crashed. It's a well known problem that it does once in a while, and probably unrelated to your keyboard layout setting. Locales have nothing to do with it either. So you want dead keys to work; hence you should go to Settings -> Region & Language -> Input Sources and add Portuguese (Brazil), not Portuguese (Brazil, no dead keys). – Gunnar Hjalmarsson Apr 29 at 7:01
  • I applyed the change @Gunnar Hjalmarsson, to Portuguese, Brazil only, Log out, Log in, but the problem persists. – wazeredo46 Apr 29 at 8:22
  • Then please edit your question again and show us what these two terminal commands output: 1. cat /etc/default/keyboard 2. gsettings get org.gnome.desktop.input-sources sources – Gunnar Hjalmarsson Apr 29 at 9:53
  • Hi @Gunnar Hjalmarsson... done. The second command is not recognizable. – wazeredo46 Apr 29 at 10:05
  • Weird if you couldn't run the second command. Are you really using Ubuntu? Anyway, I see that you solved the problem somehow. Good to hear that. – Gunnar Hjalmarsson Apr 29 at 18:39
1

Ho my GOSH, I understood now. I mixed many different attempts consecutively and aplyed the last wich was wrong. The right approach is:

walter@walter-POS-EIBTDB:~$ sudo update-locale LANG=pt_BR.UTF-8 
[sudo] password for walter: 
walter@walter-POS-EIBTDB:~$ sudo locale-gen
Generating locales (this might take a while)...
  pt_BR.UTF-8... done
  pt_PT.UTF-8... done
Generation complete.
walter@walter-POS-EIBTDB:~$ õíõ :-)

My special thanks to: @Gunnar Hjalmarsson

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.