1

I have just fresh-installed Kubuntu 20.04 on my PC. I had to modify smb.conf in order to access to my old multimedia hard drive connected to the same network and to another hard drive plugged through USB to my router.

The modification consists in adding the following lines to the [global] section fo smb.conf:

client min protocol = NT1

client lanman auth = yes

client ntlmv2 auth = no

as both hard drives refused to work with SBM2 or SMB3 protocols and as the multimedia hard drive did not need any password.

The problem is that now I can get access to both drives but the files in these drives are shown on Dolphin and Konqueror as folders.

If I double-click on any of the files I get a message saying: 'The file or folder smb://xxx/yyyy/zzzz/aaaa/bbbbb.avi does not exist' no matter what kind of file it is.

If I try to move a file to, let's say the desktop, I get 'smb://xxx/yyyy/zzzz/aaaa/bbbbb.avi is a file, but a folder was expected.'

When I try to create a text file or a spreadsheet file I also get 'A folder named smb://xxxx/zzzz/Text File.txt already exists.'

Funnily enough, when I access the drives through ftp, files show and behave correctly.

I have shared the whole home folder in my PC and if I access through samba to my home folder Dolphin shows correctly files and folders.

This makes me think that the SMB2 or SMB3 protocol is being used when I access to my own computer trough samba and the files are correctly displayed, and that there must be a bug when the SMB1 protocol is used with the other two network drives.

Any ideas?

Thanks

Edit: I have just realized that some of the files are correctly displayed and almost behave as expected, but just a few of them in some folders and subfolders. I can't see any special thing in their names than makes them appear as propper files. But if I double-click on them Dolphin says again the url is a file, but a folder was expected.. When I right-click on them Dolphin shows as the first option in the context menu to open it with the right associated programme (eg. .avi -> VLC) and the associated programme opens the file. But this happens with just a few files in every folder or subfolder, and not in all of them.

0
1

I have the same problem. But it doesn't depend on Dolphin. I tried with Konqueror, Krusader, Nautilus: nothing changes. Maybe it depends on smb1 protocol that from Samba 4.11 is deprecated (https://www.samba.org/samba/history/samba-4.11.0.html). Maybe you could think to file a bug to https://bugzilla.samba.org

P.S. I've just discovered that there is a bug in Ubuntu too: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1872476 It seems they can fix it today...


Update:

It seems they fixed the bug: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1872476 You have to update some samba files.

1
  • There has been an update today and the problem has apparently been solved. – juanlucer May 21 '20 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.