3

I am trying to install Nuxeo on Ubuntu 20.04.

I executed the commands from the nuxeo docs:

sudo add-apt-repository "deb http://apt.nuxeo.org/ $(lsb_release -cs) releases"
sudo add-apt-repository "deb http://apt.nuxeo.org/ $(lsb_release -cs) fasttracks"

But somewhere in the output the following error is shown:

"Err:9 http://apt.nuxeo.org focal Release
  404  Not Found [IP: 54.93.38.62 80]
The repository 'http://apt.nuxeo.org focal Release' does not have a Release file."

I have successfully installed Nuxeo on Ubuntu 18.04.

I also tried:

sudo add-apt-repository "deb http://apt.nuxeo.org/ bionic releases"

But I still get the same error as above.

I tried to manually edit the /etc/apt/sources.list and change from focal to bionic only for the nuxeo repository. But then if I do:

sudo apt-get install nuxeo

I get:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nuxeo : Depends: ufraw but it is not installable
         Recommends: apache2 but it is not going to be installed
         Recommends: libavcodec-extra-53 but it is not installable
E: Unable to correct problems, you have held broken packages.

I am not familiar with Linux, how are such situations resolved? Do you need to downgrade to the previous version (bionic)?

1
  • I ended up installing 18.04 instead.
    – dreameral
    Apr 28, 2020 at 9:46

1 Answer 1

2

You have done the first part:

wget http://apt.nuxeo.org/nuxeo.key -O - | sudo apt-key add

sudo add-apt-repository "deb http://apt.nuxeo.org/ bionic releases"
sudo add-apt-repository "deb http://apt.nuxeo.org/ bionic fasttracks"

So now the question is transformed to installation of ufRAW on 20.04 LTS.

mkdir -p ~/Downloads/ufraw
cd ~/Downloads/ufraw

wget http://archive.ubuntu.com/ubuntu/pool/universe/u/ufraw/ufraw-batch_0.22-3.1~build0.18.04.1_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/e/exiv2/libexiv2-14_0.25-3.1ubuntu0.18.04.5_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/g/gtkimageview/libgtkimageview0_1.6.4+dfsg-2_amd64.deb

wget http://archive.ubuntu.com/ubuntu/pool/universe/u/ufraw/ufraw_0.22-3.1~build0.18.04.1_amd64.deb

sudo apt-get install ./*.deb

and then you will be able to install Nuxeo with

sudo apt-get install nuxeo
3
  • I didn't need this since I installed 18.04 instead. But now I returned to this question, because a colleague of mine was in the same situation. And your suggestion works perfect! Thanks!
    – dreameral
    Aug 26, 2020 at 9:28
  • I want to install a package named diffuse which is available in bionic and not in focal, I want to refer to bionic repo for installing this package. Can you please elaborate and explain your answer in a better way. I am not able to get the steps exactly. @N0rbert Oct 21, 2020 at 19:11
  • For diffuse use the other answer - askubuntu.com/a/1236255/66509 .
    – N0rbert
    Oct 21, 2020 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.