I am trying to install MegaSync on my new ubuntu 20.04 installation =). They already have a version out for ubuntu 20.04. (See https://mega.nz/sync). However, when I try to install it with sudo dpkg -i megasync-xUbuntu_20.04_amd64.deb I get a big list of dependency errors. It seems to me Megasync is missing some packages. However when I open the software updater it says there are no new updates that need to be done. I am not so experienced with Ubuntu yet so any help would be greatly appreciated.

Selecting previously unselected package megasync.
(Reading database ... 195014 files and directories currently installed.)
Preparing to unpack megasync-xUbuntu_20.04_amd64.deb ...
Unpacking megasync (4.3.1-15.1) ...
dpkg: dependency problems prevent configuration of megasync:
 megasync depends on libc-ares2 (>= 1.7.4); however:
  Package libc-ares2 is not installed.
 megasync depends on libcrypto++6; however:
  Package libcrypto++6 is not installed.
 megasync depends on libmediainfo0v5 (>= 0.7.56); however:
  Package libmediainfo0v5 is not installed.
 megasync depends on libqt5core5a (>= 5.12.2); however:
  Package libqt5core5a is not installed.
 megasync depends on libqt5dbus5 (>= 5.0.2); however:
  Package libqt5dbus5 is not installed.
 megasync depends on libqt5gui5 (>= 5.8.0) | libqt5gui5-gles (>= 5.8.0); however:
  Package libqt5gui5 is not installed.
  Package libqt5gui5-gles is not installed.
 megasync depends on libqt5network5 (>= 5.1.0); however:
  Package libqt5network5 is not installed.
 megasync depends on libqt5svg5 (>= 5.6.0~beta); however:
  Package libqt5svg5 is not installed.
 megasync depends on libqt5widgets5 (>= 5.11.0~rc1); however:
  Package libqt5widgets5 is not installed.
 megasync depends on libzen0v5 (>= 0.4.31-2~); however:
  Package libzen0v5 is not installed.

dpkg: error processing package megasync (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu2) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:

2 Answers 2


You have to use apt / apt-get instead of dpkg. They will install dependencies for package:

sudo apt install ./megasync-xUbuntu_20.04_amd64.deb
  • 1
    Thanks! The ./ is very important, otherwise it doesn't work! Jun 26, 2021 at 20:28

None of the solutions I found in the web worked so I tried the following:

I downloaded libcrypto++9 from here, and installed it as a .deb. http://archive.ubuntu.com/ubuntu/pool/universe/libc/libcrypto++/libcrypto++9_5.6.1-6_amd64.deb

The same for libc6 from: http://ftp.br.debian.org/debian/pool/main/g/glibc/libc6_2.31-4_amd64.deb

Then I downloaded libqt5gui5-gles_5.15.1+dfsg-2_amd64.deb from http://ftp.br.debian.org/debian/pool/main/q/qtbase-opensource-src-gles/libqt5gui5-gles_5.15.1+dfsg-2_amd64.deb

You should do it with any package that is missing in your own configuration. I recomend this website to find them: https://pkgs.org/

  • 1
    This answer can break a system since it not only advises installing software from .deb files, but the answer also suggests installing packages from other distributions. Additionally, pkgs.org is not an official mirror or source for Ubuntu software. When there are official sources like packages.ubuntu.com, referring users to unofficial software sources poses an unnecessary risk. This answer also lacks formatting, which is needed so the names of packages can be distinguished from the surrounding text.
    – Nmath
    Nov 8, 2020 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.