55

In 10.10 that I was using before 12.04, you could use Alt+F9 to minimize a window to the task bar.

In 12.04 Meta+Ctrl+/ maximizes and unmaximizes a window.
If you have a numeric keypad you can use Ctrl+Alt+0 to minimize to launcher.

On my netbook I don't have a numeric keypad and the normal numbers do not work with the above shortcut. How can I minimize windows with a keyboard shortcut?

1
  • ALT+F9 works for me in MATE. But I wish they added shortcut labels to the right click menu on the window title.
    – neverMind9
    Nov 6, 2018 at 21:15

4 Answers 4

53

I prefer the default bindings instead of needing customised ones:

  • Alt+Space then pressing N to Minimize
  • Alt+Space then pressing X to Maximize/Un-maximize

This also happens to be the default in Microsoft Windows.

Unfortunately it's different for GNOME Shell. There you press:

5
  • 2
    alt-space, x to maximize Apr 18, 2012 at 23:06
  • 1
    There is a bug report on gnome-shell (v3.14+, previously i twas handled by gtk) about this problem. Instead we have Super+(Up/Down) to Maximize/Unmaximize. May 14, 2017 at 18:06
  • 1
    Super+H can minimize the window on GNOME.
    – ICE
    Apr 14, 2019 at 17:15
  • Super+<Number> brings up the window in the dash or minimizes it if it is already open. This is enough if you just want to minimize your currently open window.
    – Nash
    Jun 11, 2019 at 13:40
  • When we do alt+space in Ubuntu 18.04 it opens the menu but the usual keys don't work (for minimizing, maximizing, moving, etc).
    – Daniel
    May 26, 2020 at 11:46
46

Launch keyboard:
enter image description here
Shortcuts, windows, minimize window, click at the right of the bar as indicated
enter image description here
It will toggle to new accelerator. Just press CTL + ALT + 0 not the numpad zero.

Do note that the numpad zero shortcut will no longer work after you do this. Shortcuts now make a distinction between numpad numbers and across the top numbers, although it isn't noted as 'numpad0' in the keyboard wizard.

4
  • I use a German keyboard and this deafult shortcut is the same, but not working. Jun 29, 2014 at 17:06
  • 11
    Does not work on Ubuntu 18.10 in gnome shell: there is no "Minimize window" option.
    – Lexible
    Jan 24, 2019 at 18:44
  • 7
    Search for Keyboard Shortcuts > Hide Window : Super+H
    – austin
    Mar 3, 2020 at 22:12
  • 1
    There is no "minimize window" entry in keyboard shortcuts for Ubuntu 18.04, like @austin said it's called "hide window" and set to Super+H.
    – Daniel
    Jul 8, 2020 at 8:26
9

If your keyboard has 'windows' key, also known as 'Super' in Ubuntu, you can minimize, maximize, left-restore or right-restore using the key combinations:

  • Ctrl + Super + Up arrow = Maximize or Restore (toggles)
  • Ctrl + Super + Down arrow = Restore then Minimize
  • Ctrl + Super + Left arrow = Restore to left
  • Ctrl + Super + Right arrow = Restore to right
7

If you wish to continue to use Alt+F9 then you can. For unity* just set to it in system settings > keyboard > shortcuts > windows as seen in the screenshot in aking1012's answer

For gnome-shell you need to set in gsettings, either graphically in dconf-editor as in screen or thru gsettings

gsettings set org.gnome.desktop.wm.keybindings minimize "['<Alt>F9']"

enter image description here

3
  • FWIW, in gnome-shell 3.4.1 the proper gsettings keybinding is "['<Alt>F9']" (without the + sign).
    – Dan O
    Aug 11, 2012 at 14:44
  • This works perfectly in Ubuntu 18.10.
    – Lexible
    Jan 24, 2019 at 20:58
  • ...and seems the only way to achieve this in ubuntu 19... thanks
    – Edoardo
    Jun 14, 2019 at 10:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.