This is on a machine I upgraded from 18.04 to 20.04 a few days ago. No issues at all getting sound to play out of headphones on 18.04.

The headphones are paired with Bluetooth. I unpaired and repaired them just to be sure. The settings panel for sound has them as an output option and I can select it without issue. However, no sound ever comes out of the headphones. I've even adjusted the volume both in the settings panel, in alsamixer and in pavucontrol. Nothing changes.

I see no errors in the bluetooth service log.

Output of:

{ sudo lshw | grep product | head -n1 && sudo lspci -knn | grep Net -A3 && lsusb -v; } >output.txt 2>&1


  • 1
    You could try option # 3 here
    – Raffa
    Apr 27, 2020 at 21:53
  • 1
    @K7AAY: there is a huge amount of information in the output, far more than I can put in here. I put it in a pastebin: pastebin.com/VJ5EQcFb
    – siride
    Apr 27, 2020 at 22:36
  • 1
    @Raffa: already done, along with uninstalling and reinstalling Alsa and such (option #2). I try to do my homework before ever asking questions.
    – siride
    Apr 27, 2020 at 22:38
  • 1
    @Raffa, option 3 worked for me on Ubuntu 20.04LTS : I could connect to my bluetooth speaker but even though I chose it as sound output, the sound would still come out of my HDMI screen. Now it works : thank you !
    – Polypheme
    Nov 5, 2020 at 23:13

7 Answers 7


This is a bug (pulseaudio #832, launchpad #1866194) with new version of pulseaudio in Ubuntu 20.04 where old config values have not been cleared and it is not routing to the correct device. The solution is to delete the old config and restart pulseaudio:

Open a terminal (Ctrl+Alt+T) and run the following commands:

mv ~/.config/pulse/ ~/.config/pulse.old
systemctl --user restart pulseaudio

A pulseaudio fix #298 is currently in progress.

  • 20
    +1 this is the only solution that worked for me.
    – begumgenc
    Jun 8, 2020 at 11:13
  • 1
    Work for me on Kubuntu.
    – Erich
    Jul 12, 2020 at 4:57
  • 2
    nice, worked for me also, and if want to remove the old pulse config once you succeed restarting it, just: rm -rf ~/.config/pulse.old
    – Amine M
    Jul 21, 2020 at 9:07
  • 2
    In my case there was no sound from one bud, this solution worked in that case too.
    – Ashwani
    Aug 18, 2020 at 7:15
  • 2
    This worked for me, but wondering if the fix was merged in for pulseaudio control, will it get updated for 20.04 at some point during system updates?
    – nemaroller
    Apr 15, 2021 at 17:41

It's not a fix, only a workaround; I installed pulse audio volume control utility:

sudo apt-get install pavucontrol

The problem seems that Ubuntu doesn't change all the audio sources to the Bluetooth device, in the volume control utility you will see this more clearly, the Bluetooth device is connected but not used as audio playback device. (see pulse audio volume control utility).

Find your audio source; mine was firefox since I was playing some videos from YouTube, and select the Bluetooth playback device (mine was a Xiaomi speaker) (XMFHZ02) and change it. Your device should start outputting audio.

Hope it helps

  • thanks! It was clear as you mentioned after opening the pulseaudo volume control what the problem is. Worked for QuietComfort 35 II Headphone. It is even switching back to headphone as output after turn the headphone off and on again.
    – Baris
    May 1, 2020 at 17:02
  • 4
    doesn't seem to work for me
    – Grateful
    May 7, 2020 at 2:50
  • for me working selecting the bluetooth May 18, 2020 at 15:03
  • Does not work for me (Tzumi earbuds). Pavucontrol only shows plugged in audio. The a2dp driver does not load. I have to connect/reconnect. Not a big deal.
    – ross minet
    Jun 6, 2020 at 11:15
  • This worked well for me. You can also select the application using sound.
    – NixMan
    Oct 6, 2020 at 16:33

I reinstalled, and it worked, without having to reboot:

sudo apt install --reinstall pulseaudio pulseaudio-module-bluetooth

Then re-connect the Bluetooth headset

  • I know this is somehow not completely relevant BUT it saved me from a problem that I had for quite long time... So. I couldn't change audio profiles (in order to use the headsets microphone) and I could only use A2DP Sink (only for listening)
    – kostia
    Jan 5, 2021 at 10:57
  • this WORKED for me in debian buster stable. thanks!
    – Allexj
    Apr 9, 2021 at 22:15
  • amazing... just reinstalled it make everythingworks LOL Oct 22, 2021 at 15:12
  • This solved my problem. Thanks!
    – scarface
    Dec 5, 2021 at 16:04
  • Worked for me on Ubuntu 22.04
    – Marged
    Jun 29, 2022 at 14:08

I had a similar problem, this worked for me.

Install Pulse Audio with Bluetooth module:

$ sudo apt install pulseaudio pulseaudio-module-bluetooth

Open it and select the desired output channel in Playback tab.

The tool allows tweaking also other sound settings.


Option #3 as described here worked for me.

Additionally info:

  • I upgraded from 19.10 to 20.04

  • When adjusting the volume via the volume up/down hotkeys the feedback sound would play through the headphones. They were also detected in the settings. The audio stream from other applications would still play through the laptop speakers.

  • The packages @Mirek mentioned, pulseaudio and pulseaudio-module-bluetooth were already installed


If you are using Ubuntu 20.04, I would recommend to replace Pulseaudio with Pipewire. It will work with all your apps, because it aims to replace both PulseAudio and JACK, by providing a PulseAudio-compatible server implementation and ABI-compatible libraries for JACK clients..

I run Ubuntu 20.04.3 and Pipewire runs very stable so far. My bluetooth headset works with Microsoft Teams now. In my case I run Bitwig, Spotify, Youtube etc. at the same time and it just works with every output device (Bluetooth Headset, RME Audio Interface, internal speakers).

I post the link for the installation steps, which worked for me: Replacing Pulseaudio with Pipewire in Ubuntu 20.04


After a few reboots, it seems to be working. I'm not sure specifically which thing worked, but here are the things I tried.

  1. Everything in this answer: Ubuntu 18.04: Audio doesn't work unless I switch between outputs
  2. Un-pairing and re-pairing my BlueTooth headphones. I am using blueman-applet.
  3. Muting and unmuting the sound in AlsaMixer across all devices.
  4. Selecting, deselecting and reselecting the headphones output in the configuration panel for sound.
  • I just upgraded to ubuntu 20... And it doesn't seem to be working for me! Anyone have any suggestions?
    – Grateful
    Apr 29, 2020 at 7:28
  • Same here - installed from scratch 20.04 and no sound. Actually, Bluetooth "tester" in Settings works well. But none of the applications can emit sound. Apr 29, 2020 at 19:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .