I recently upgraded a 10.10 server (headless, EC2) to 11.04 and then to 11.10. Both upgrades seem to have worked, but now my terminal acts differently, particularly concerning output scrolling. I am accessing this server via Terminal on a 11.10 Desktop (GNOME fallback).

10.10 Behavior:

  • A scroll bar is displayed on the right side of my Terminal, allowing me to scroll back to older output
  • Turning the mouse wheel scrolls back to older output

11.10 Behavior:

  • No scroll bar is visible
  • Turning the mouse wheel cycles the current line through my command history (same as UP key)

This is a difficult issue to describe succinctly and I've had no luck finding any information about this. But I've performed the same upgrade several times (10.10->11.10) and the result is always the same concerning Terminal scrolling. Output scrolling is very important to me and something I take for granted - I'm concerned I'll be unable to work effectively on this server until I resolve this.

Update - Problem magically gone after logout/login Well, as I said I've done the same upgrade several times and encountered the same problem. However, in the previous tries I was scared away and gave up. This time I was more determined to finish the upgrade and by simply logging out and back in to the server via SSH the problem has corrected itself.

3 Answers 3


The behaviour you describe sounds like your terminal was stuck in the full screen "cursor addressing" mode used by tools like less and vi.

The mode can become stuck if those programs do not exit cleanly. For instance, if you kill -9 them, or are running them through an ssh session that disconnects. You can exit this terminal mode by running the following command:

tput rmcup

Or just try browsing a file with less and quit as normal. You should then have access to your scrollback and the contents of the screen when cursor addressing mode was entered.

  • 16
    tput rmcup didn't make any visible change, but tput reset did the trick.
    – wallyk
    Feb 11, 2014 at 18:11
  • 12
    In Ubuntu 14.04 this problem occurs for me if an SSH session within the Terminal is broken. Just viewing a file with less and quitting works perfectly - easier to remember than the tput commands.
    – Eborbob
    Nov 29, 2015 at 20:15
  • 4
    Looks like tput reset did the trick for me. Sep 26, 2016 at 14:37
  • another possible culprit for this effect is imwheel running (not a default in Ubuntu 16.04, but readily available) Nov 17, 2016 at 12:00
  • Neither the less trick nor tput is not working for me on 14.04.
    – mitchus
    Dec 2, 2016 at 13:20

If tput rmcup does not work, try

tput reset



Just reset alone worked for me.

  • Worked for me on linux alpine May 23, 2021 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.