3

I'm trying to install SRA toolkit on my Ubuntu 20.04 TLS with the following command:

sudo apt-get install sra-toolkit

I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package sra-toolkit is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'sra-toolkit' has no installation candidate

I had installed this package with the same command on Ubuntu 18.04, but now it doesn't work. Any idea what might be the problem?

3
  • There is no sra-toolkit in focal repos.
    – Pilot6
    Apr 27, 2020 at 16:34
  • Thank you so much. If I go back to 18.04 will the problem be resolved?
    – Parnian
    Apr 27, 2020 at 17:11
  • Yes, the package is available in the 18.04 repos. But you can install to 20.04 from source.
    – Pilot6
    Apr 27, 2020 at 17:13

1 Answer 1

2

The sra-toolkit is not available in 20.04 LTS (focal), but you can install it manually by using packages from 19.10 (eoan):

cd ~/Downloads
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/n/ncbi-vdb/libncbi-vdb2_2.9.3+dfsg-2_amd64.deb
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/n/ncbi-vdb/libncbi-wvdb2_2.9.3+dfsg-2_amd64.deb
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/s/sra-sdk/sra-toolkit_2.9.3+dfsg-1build2_amd64.deb

sudo apt-get install ./libncbi-vdb2_2.9.3+dfsg-2_amd64.deb
sudo apt-get install ./libncbi-wvdb2_2.9.3+dfsg-2_amd64.deb

cat <<EOF | sudo tee /etc/apt/preferences.d/pin-sra-libs
Package: libncbi-vdb2
Pin: version 2.9.3+dfsg-2
Pin-Priority: 1337

Package: libncbi-wvdb2
Pin: version 2.9.3+dfsg-2
Pin-Priority: 1337
EOF

sudo apt-get install ./sra-toolkit_2.9.3+dfsg-1build2_amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.