6

I ran

:~$ apt install pulseaudio-equalizer

An important detail, no icon was included in the Gnome Applications menu. I think it is important to fix it. So, I ran

:~$ qpaeq

and I received the error messages

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use  QT_QPA_PLATFORM=wayland to run on Wayland anyway.
There was an error connecting to pulseaudio, please make sure you have the pulseaudio dbus module loaded, exiting…

I ran

:~$ pulseaudio

and I received the message

E: [pulseaudio] pid.c: Daemon already running.  
E: [pulseaudio] main.c: pa_pid_file_create() failed.

So, I loaded the modules that were missing

:~$ pactl load-module module-equalizer-sink  
:~$ pactl load-module module-dbus-protocol

and the equalizer opened and it didn't work (the sound wasn't changing).

Another important detail, why do theses modules are not loaded by default? I think this is another thing to be fixed.

I created the file ~/.config/pulse/default.pa with the lines

load-module module-equalizer-sink  
load-module module-dbus-protocol

and I restarted to check. After the Gnome login the computer start to "freeze" by some seconds. In this condition, if I run

:~$ pactl list modules short | grep module-dbus-protocol

the terminal stops until I do Crtl+C.

If I try to load some module (module-equalizer-sink or module-dbus-protocol) I received an error message. So strange...

I restarted the computer again and the "freezing" happened again. So, in this way I deleted the file ~/.config/pulse/default.pa to come back to the early situation. I restarted and the "freezing" didn't happened again.

I tried another solution. I installed

:~$ apt install pulseeffects

and the equalizer was not working. Looking the pulseeffects FAQ,

https://github.com/wwmm/pulseeffects/wiki/FAQ

I found a solution, to run

:~$ apt install lsp-plugins

Delete the folder ~/.config/gstreamer-1.0 (if it exists)

After to close the pulseeffects (if is opened) and run

:~$ dconf reset -f /com/github/wwmm/pulseeffects/

In this way, the equalizer of the pulseeffects worked.

3
  • 1
    One thing you should know: if ~/.config/pulse/default.pa exist, pulseaudio will not read from /etx/pulse/default.pa, so if you create user configuration in ~/.config/pulse/default.pa, you should copy content from /etc/pulse/default.pa to ~/.config/pulse/default.pa first and then edit it. Please take a look at man default.pa.
    – mook765
    Apr 27, 2020 at 17:04
  • Thank you @mook765. I didn't pay attention to this important detail. I will try after if works. :) Apr 28, 2020 at 3:19
  • Do I read this correctly your question has the answer at the bottom of the question?
    – David
    Feb 4 at 6:19

2 Answers 2

3

Considering the comment of @mook765 above, I included the lines

### Modules for the Equalizer
load-module module-equalizer-sink
load-module module-dbus-protocol

in the end of the file /etc/pulse/default.pa. I checked the modules were not present and commented in the file originally.

I rebooted and I observed Gnome didn't "freeze" more after the login.

I ran qpaeq and the equalizer opened normally. I played an audio in the VLC and after in the Audacity to do some tests and the equalizer was not working.

I opened the Gnome Settings and I found a new device in Gnome Settings > Sound > Output > Output Device called FFT based equalizer on Built-in Audio Analog Stereo. When I selected this option the sound mute, so that, it didn't work. I pressed the Test button and there was no sound.

So, the pulseaudio-equalizer continue not working.

Highlighting, at last I guess there are two important points to be fixed in the Ubuntu 20.04 for pulseaudio-equalizer:

  1. Include the qpaeq icon/shortcut in the Gnome Applications after the pulseaudio-equalizer installation.

  2. Load the modules module-equalizer-sink and module-dbus-protocol and include than in the /etc/pulse/default.pa file after the pulseaudio-equalizer installation.

Beyond this, there is a third important point to be fixed: what is missing to the pulseaudio-equalizer to work? :)

3
  • Please see this answer, this worked for me. I just installed pulseaudio-equalizer in 20.04 and faced the same problems. I remember that I once wrote an answer about this topic and tried the mentioned solution, it worked.
    – mook765
    May 31, 2020 at 16:04
  • I forgot to mention that I installed pulseaudio-equalizer from the official repository now, no need to add PPA as described in the linked answer.
    – mook765
    May 31, 2020 at 16:13
  • I found that the answer that @mook765 linked above fixes the problem for me. The key point is installing pavucontrol and configuring the program you're equalizing to use "FFT based equalizer on [device]". I set up pulseaudio-equalizer to run through pulseeffects, as I found that the equalizer still didn't actually change the audio in pulseeffects, but that may not be an issue for you. I also recommend checking this answer to set up the pavucontrol to be automatic, so it doesn't reset.
    – Para_lyzed
    Jun 18, 2020 at 21:20
2

Problem symptom: I faced a similar problem - after upgrading from Ubuntu 18.04.5 to 20.04.1, pulseaudio-equalizer could not be enabled:

$ pulseaudio-equalizer enable
PulseAudio Equalizer/LADSPA Processor 4.0 (29.01.2017)

... (10 lines omitted)

Equalizer status: [disabled]
Equalizer configuration status: [enabled]
Equalizer plugin: [mbeq_1197/mbeq]

... (3 lines omitted)

(That is, I tried to enable pulseaudio-equalizer but it remained disabled)


Problem crux: When I upgraded from Ubuntu 18.04.5 to 20.04.1, /usr/lib/ladspa/lsp-plugins-ladspa.so seem to have disappeared.

I realized this after seeing this thread about the equalizer in pulseeffects being greyed-out, where it turns out the OP was missing LSP.


Solution: Similar to the workaround where you installed lsp-plugins, I went to the LSP website, downloaded the latest lsp-plugins-ladspa, extracted lsp-plugins-ladspa.so and placed it in /usr/lib/ladspa/.

Afterwards, $ pulseaudio-equalizer enable works as expected, and I don't need pulseeffects.

Not the answer you're looking for? Browse other questions tagged or ask your own question.