1

I have the GNOME calendar installed and it works fine.

But there is a problem, it is not the default calendar and I can not select it. In the calendars category, only a text editor is available (apparently by mistake).

I am sure that this is a bug, and really look forward to fixing it in Ubuntu. In the meantime, I hope that someone will tell me how to fix this manually.

enter image description here

1
4

An even easier solution would be to set the value with gio itself. Thus, set with the command:

gio mime text/calendar org.gnome.Calendar.desktop

Then check what you just did with the following command:

gio mime text/calendar 
3

Try this

gedit /home/yourname/.local/share/applications/mimeapps.list

paste text/calendar=org.gnome.Calendar.desktop at the end of [default applications] and save.

by querying gvfs-mime --query text/calendar

you should get

Default application for 'text/calendar': org.gnome.Calendar.desktop
Registered applications:
        org.gnome.Calendar.desktop
1
  • 1
    gvfs-mime --query text/calendar has been replaced by gio mime text/calendar in 20.04. – heynnema Jun 13 '20 at 17:18
2

What worked for me was:

Open Terminal:

locate mimeapps.list

Find the path starting with home: /home/user_name/.config/mimeapps.list

Then run the below commands.

vim /home/user_name/.config/mimeapps.list

or

gedit /home/user_name/.config/mimeapps.list

(both vim and gedit allow you to edit text files)

paste text/calendar=org.gnome.Calendar.desktop under the last application in the default application list

enter image description here

Save the file and run the below command:

gio mime text/calendar

Note the following enter image description here

And lastly check your default applications under the Ubuntu settings: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.