5

I'm running Lubuntu on Virtualbox on a PC. I've shared a folder (via the Lubuntu menu) on my PC so that I can transfer files to and from my Lubuntu instance.

However, when I try opening it I get the following error:

Error opening directory “/media/sf_MOVIES_AND_SERIES”: Permission denied.

Any ideas?

Thanks!

2
  • add your user to the vboxfs group
    – cmak.fr
    Commented Apr 27, 2020 at 15:33
  • if MOVIES_AND_SERIES directory is also mount point on host OS, try to change shared folder path into a directory in MOVIES_AND_SERIES.
    – tabata
    Commented Feb 13, 2021 at 8:19

1 Answer 1

5

Any ideas?

Check help

For Linux and Oracle Solaris guests, access is restricted to members of the group vboxsf

Add user to vboxsf group

sudo adduser <username> vboxsf
2
  • 1
    That gave some sort of an error ( I don't remember what exactly), so I continued looking and this worked: sudo usermod -G vboxsf -a username ln -s /media/sf_shared/ name_of_link.
    – Gottano
    Commented Apr 27, 2020 at 15:57
  • 3
    @Gottano after running sudo adduser myUserName vboxsf, I restarted the VM and it worked for me.
    – Sparky
    Commented Sep 22, 2020 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .