24

I upgraded from Ubuntu 18.04 to 20.04 but desktop files and icons are missing, How do I should solve this problem?

4
  • if i remember well, desktop folder is handled in a different manner since 19.04 - if this is the only issue you are facing, good to you, in other case i would go for a fresh install of Focal. – cmak.fr Apr 27 '20 at 15:35
  • Indeed, an upgrade may be hit and miss. Check whether the gnome shell extension Desktop Icons is installed and active, which is the case in a fresh install. – vanadium Apr 27 '20 at 15:37
  • @vanadium I checked for Desktop Icons extension, which wasn't active and even installed. I did try to install it but couldn't. – The Mir Apr 27 '20 at 18:43
  • 1
    OK, you will then need to install the Desktop Icons extension yourself: "sudo apt install gnome-shell-extension-desktop-icons", and then activate the extension in Gnome Tweaks (or the new "Extensions" app). – vanadium Apr 28 '20 at 8:44
18

This worked for me:

  • Install gnome-shell-extension-desktop-icons:
sudo apt install gnome-shell-extension-desktop-icons
  • Log out of Gnome.
  • Log back in.
3
  • Yeah, It worked but there are a bunch of other problem/bugs. I can't open or remove a file on desktop using keyboard, do you have the same problem? – The Mir May 4 '20 at 11:04
  • 5
    You don't need to log out. Simple ALT-F2 R will do the job aswell. – Galvani May 5 '20 at 15:54
  • 1
    just restarting worked for me, but it's ALT-F2 r (lower case r) – Andy Mar 1 at 11:17
4

The problem might be that the installation did not go according to plans, not to worry though! The simplest (and most effective) operation you can do is:

sudo apt dist-upgrade

This will automatically install / update / repair all the needed packages for your current version.

3
  • 3
    worked perfectly. – Abdeali Chandanwala Oct 13 '20 at 6:00
  • 1
    The accepted answer does not for me. After sudo apt install gnome-shell-extension-desktop-icons, I cannot gui login ubuntu again :( Since I missed lots of packages, gnome-shell-extension-desktop-icons just one of them. But sudo apt dist-upgrade works perfect for me. – new2cpp Dec 15 '20 at 11:52
  • 1
    By far should be the accepted answer! – yossico Jan 11 at 0:33
1

Try switching desktop manager.

I also just upgraded my stable 18.04 to 20.04. Initially I can't even see my initial login prompt and I have forgotten that I installed lightdm and made that the default vice gdm (gnome desktop manager) which is version 3 now (gdm3).

I followed this nice how-to: Switch Display Manager in Ubuntu 20.04

You can have both gdm3 and lightdm installed but one can only be set active.

Good Luck!

2
  • Also, you can always drop to TTY mode from the desktop manager GUI by [Ctrll-Alt-F1 to F4] depending on the run level you need to be. Try run-level 4 first with your sudoer password. – Quantanglement Apr 29 '20 at 18:11
  • Return to the desktop manager GUI with [Ctrl-Alt-F7] from the TTY – Quantanglement Apr 29 '20 at 18:12
1

I'm on stock Ubuntu 20.04.2, fresh install.

I also noted out of the blue, that the contents of ~/Desktop failed to show up on the desktop.

So I went ahead and enabled the Desktop Icons extension in Tweaks, and nothing happened. After I have restarted the Gnome Shell with Alt+F2 + r, and still no icons, I went back to Tweaks only to find the Desktop Icons extension disabled again. So I repeated the cycle, this time tweaking on the extension's preferences, hoping that it would unstuck the glitch somehow. No luck, the Desktop Icons extension kept disabling itself on each restart of Gnome Shell.

Then I looked in dconf-editor, in org.gnome.shell enabled-extensions: "desktop-icons@csoriano" was in there, as it was supposed to be. Yet the problem persisted.

Then:

I do have an additional piece of GUI window, that is called, plainly, Extensions in the apps / activies overview. It's a single window, and looks very similar to Gnome Tweaks' "Extensions" tab UI. Only, this one takes precedence over the one in Tweaks.

I don't know where this Extensions app originates from: whether it's installed on 20.04 by default, or maybe I have obtained it by installing the gnome-shell-extensions package.

Anyways, enabling Desktop Icons in the plain Extensions app solved everything.

3
  • 1
    The only solution among those proposed above that worked for me. Thanks! I would never have thought that a second "Extension" GUI existed. No idea where it came from... – Philippe P May 6 at 11:52
  • @PhilippeP you are on a lucky streak today: askubuntu.com/q/1329463/1157519 :D – Levente May 6 at 12:46
  • 1
    Similar to your solution, but for me worked enabling "Extensions" itself, in the same GUI – PolyGlot Jun 23 at 8:12
1

I tried sudo apt install gnome-shell-extension-desktop-icons but it did not work for me because my gnome shell was fully updated, but I just right clicked on the desktop and created a folder then just like that all my icons appeared; hope this helps out.

0

I have Ubuntu 20.04 (Gnome) and sometimes icons are missing after restart. I use a rather silly solution. I just create a new file, this causes the gnome to load the desktop icons again. ctrl+alt+t to open a terminal, then:

touch Desktop/NEW #Creates an empty file named NEW
rm Desktop/NEW #Deletes the file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.