21

I upgraded from Ubuntu 18.04 to 20.04 but desktop files and icons are missing, How do I should solve this problem?

4
  • if i remember well, desktop folder is handled in a different manner since 19.04 - if this is the only issue you are facing, good to you, in other case i would go for a fresh install of Focal. – cmak.fr Apr 27 '20 at 15:35
  • Indeed, an upgrade may be hit and miss. Check whether the gnome shell extension Desktop Icons is installed and active, which is the case in a fresh install. – vanadium Apr 27 '20 at 15:37
  • @vanadium I checked for Desktop Icons extension, which wasn't active and even installed. I did try to install it but couldn't. – The Mir Apr 27 '20 at 18:43
  • 1
    OK, you will then need to install the Desktop Icons extension yourself: "sudo apt install gnome-shell-extension-desktop-icons", and then activate the extension in Gnome Tweaks (or the new "Extensions" app). – vanadium Apr 28 '20 at 8:44
15

This worked for me:

  • Install gnome-shell-extension-desktop-icons:
sudo apt install gnome-shell-extension-desktop-icons
  • Log out of Gnome.
  • Log back in.
2
  • Yeah, It worked but there are a bunch of other problem/bugs. I can't open or remove a file on desktop using keyboard, do you have the same problem? – The Mir May 4 '20 at 11:04
  • 3
    You don't need to log out. Simple ALT-F2 R will do the job aswell. – Galvani May 5 '20 at 15:54
4

The problem might be that the installation did not go according to plans, not to worry though! The simplest (and most effective) operation you can do is:

sudo apt dist-upgrade

This will automatically install / update / repair all the needed packages for your current version.

3
  • 3
    worked perfectly. – Abdeali Chandanwala Oct 13 '20 at 6:00
  • 1
    The accepted answer does not for me. After sudo apt install gnome-shell-extension-desktop-icons, I cannot gui login ubuntu again :( Since I missed lots of packages, gnome-shell-extension-desktop-icons just one of them. But sudo apt dist-upgrade works perfect for me. – new2cpp Dec 15 '20 at 11:52
  • 1
    By far should be the accepted answer! – yossico Jan 11 at 0:33
1

Try switching desktop manager.

I also just upgraded my stable 18.04 to 20.04. Initially I can't even see my initial login prompt and I have forgotten that I installed lightdm and made that the default vice gdm (gnome desktop manager) which is version 3 now (gdm3).

I followed this nice how-to: Switch Display Manager in Ubuntu 20.04

You can have both gdm3 and lightdm installed but one can only be set active.

Good Luck!

2
  • Also, you can always drop to TTY mode from the desktop manager GUI by [Ctrll-Alt-F1 to F4] depending on the run level you need to be. Try run-level 4 first with your sudoer password. – Quantanglement Apr 29 '20 at 18:11
  • Return to the desktop manager GUI with [Ctrl-Alt-F7] from the TTY – Quantanglement Apr 29 '20 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.