6

I have Intellij Idea, which has its own shortkeys bound to Ctrl + Alt + F10, and I got some weird screen blackout after pressing these keys on my Ubuntu.

I was only able to switch my screen back after pressing Super + F2.

What does this key combination do? How can I disable it?

3
  • in this case I have so far pressed Ctrl + Alt + Del and unfortunately lost all unsaved data every time. Your way (Super + F2 btw for me Super + F1 woks) seems to me to be better in his regard.
    – SL5net
    Mar 8, 2021 at 12:12
  • I tried to bind this key combination for the 'Turn off microphone' action (via the Globalse shortcut menu) but it didn't work. The same thing happens as you described in the question. (i escape with Ctrl+Alt+F1 then)
    – SL5net
    Mar 8, 2021 at 12:19
  • I would say it's very odd to be integrating a desktop distro where you can shoot yourself in the foot like that, I can hardly see why keeping this option active by the default installation is warranted. I mean, it's a rather terrible dead-end for the typical end user.
    – matanster
    Mar 16, 2021 at 22:16

2 Answers 2

9

These keys switch to virtual consoles, in as far as these are active. In a default installation of Ubuntu, no consoles are set up above Ctrl+Alt+F6, which is why you see nothing more than a blinking cursor after pressing that keyboard combination. Hit Ctrl+Alt+F2 or simply Alt+F2 to return to your graphical desktop. You have virtual consoles available on Ctrl+Alt+F3 up to F6.

5
  • 2
    Is there a way to remove these keys? I don't see anything in keyboard shortcuts settings
    – Igor
    Apr 27, 2020 at 15:52
  • 1
    btw, what's a point of having these? I am always can open up terminal inside of Linux, why do I need these external ones?
    – Igor
    Apr 27, 2020 at 15:53
  • 2
    It is the historical way of multitasking in unix, before graphical environments were started by default. The keybinding is not controlled by your desktop environment, but deeper in the basis system, perhaps at the level of the kernel?
    – vanadium
    Apr 27, 2020 at 15:57
  • i need litle modification. to return to your graphical desktop i needet Ctrl+Alt+F1. here in Kubuntue 20.4 not works Ctrl+Alt+F2 or Alt +F2 for that . Maybe Manjaro Linux does work like so?
    – SL5net
    Mar 8, 2021 at 12:24
  • @SL5net it indeed depends on how the distro is set up. On standaard Ubuntu, login manager GDM runs on TTY 1, and the user session on TTY 2. Previously, the graphical session was on TTY 7
    – vanadium
    Mar 8, 2021 at 13:22
2

As explained here https://askubuntu.com/a/1315576/1017209 you could use into your console or sh-batch-file

setxkbmap -option srvrkeys:none

to disable all ctrl + alt + Fxxx hotkeys

i have tested this in Kubuntue 20.4

1
  • I wonder if one would miss any of these combination in sane usage scenarios. The one this OP asks about is really pathological ...
    – matanster
    Mar 16, 2021 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.