2

Since I did a fresh install of 20.04 a few days ago, my keyboard shortcuts for switching workspaces no longer works. Any ideas on how to fix it? Is anybody else running into this problem?

1

2 Answers 2

5

I've been bitten by this a few times now when GNOME decide to "improve" things. The latest case was with the release of v40 where workspaces are now horizontal rather than vertical and the keybindings have been adjusted accordingly. After the change my shortcuts broke again, and no amount of fiddling would get them to "take" again. The accepted answer here doesn't get to the bottom of what's going on, and after a lot of frustration I think I know what causes this and how to fix it reliably.

When new settings are introduced, it appears that the GNOME devs aren't especially careful to cover all the upgrade cases for existing users. As a result, you can end up with shortcuts bound to window manager actions that no longer exist; they don't show up in the Keyboard Shortcuts UI and rebinding that shortcut through the UI doesn't delete the old binding. As a result, you end up with two actions bound to the same shortcut, and whether your new binding works depends on luck - which order the two appear in a non-deterministically ordered list of keybindings.

To fix this, go to the command line are run:

gsettings list-recursively org.gnome.desktop.wm.keybindings

This will produce you a list of all of the current keybindings, including those hidden in the UI. Find all of the settings that are bound to the shortcut that's causing the problem (there will be more than one, almost certainly) Clear them by running commands like:

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-down "[]"

Once you've cleared all of the pre-existing bindings for your shortcut, you should be able to go back to the settings UI and set up your shortcuts as you want them.

1
4

You can find built in keyboard shortcuts and add your own custom shortcuts in Settings > Keyboard Shortcuts.

The default keyboard shortcuts for moving between workspaces in 20.04 are Super + PgUp for Workspace Up and Super + PgDn for Workspace Down. For many keyboard shortcuts the combination of Ctrl + Alt is a substitute for the Super key.

Install gnome-tweaks

sudo apt install gnome-tweaks

and toggle from Dynamic Workspaces to Static

Retry adding a custom keyboard shortcut.

7
  • I knew where to find the shortcuts, it's just that they aren't working. I've tried the default Super + PgUp and Super + PgDn, as well as changing them to custom keys. When I perform the shortcut the overlay does show up (the dark boxes representing the workspaces and the orange box representing the active one), but when I release the keys the switching doesn't actually occur.
    – Billy
    Apr 27, 2020 at 14:25
  • 2
    Can you change workspaces with the Super key and double clicking on a new workspace in the "fly out" that appears on the right side of the screen?
    – sc608
    Apr 27, 2020 at 14:30
  • Yes, clicking on the workspaces does work.
    – Billy
    Apr 27, 2020 at 14:37
  • 1
    Do you have the Gnome Tweaks package installed, apt install gnome-tweaks. and if so have you tried toggling from Dynamic Workspaces to Static (and perhaps back)?
    – sc608
    Apr 27, 2020 at 14:50
  • 1
    Excellent! Thanks for letting me know.
    – sc608
    Apr 27, 2020 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .