4

I have Unbuntu 18.04 on Dell laptop with Pulse Audio & Gnome desktop. I have my laptop connected to a USB 3.0 dock (not USB-C) with both external speakers and a USB headset plugged into that dock. Upon waking from suspend, I find:

  1. Pulse audio server, via pactl, says the default sink is the speakers on the dock, the way I had it prior to suspend.
  2. The desktop GUI for Sound says the headphones are the default sink.
  3. When I resume playing streaming music from Amazon in the Firefox browser, it goes to the dock speakers.
  4. When I play a video with sound in the Slack desktop client it goes to the headset.
  5. When I re-select the dock speakers in the Sound GUI, then the Slack video play goes to the dock speakers.

So, every time I resume from suspend, I have to go into the Desktop Sound GUI and select the dock speakers. Fast and easy, sure, but I like my computer to work for me, not me for it.

So, any idea on the source of the discrepancy? I imagine there might be a tweak of the suspend/resume configuration that could help things. I also imagine there is a solution to the discrepancy on the default sink. Any ideas?

Here is a snapshot of the Sound GUI to which I am referring:

enter image description here

1

I did discover a mistake in my understanding of the default sink for Pulse audio. I neglected to look at the output of pactl info. Instead, I was looking at the output from pactl list. There I had indentfied the State and mistook that as indicating default when it said Running.

pactl list|grep -A 3 ^Sink

Sink #56 State: SUSPENDED Name: alsa_output.pci-0000_00_1f.3.analog-stereo Description: Built-in Audio Analog Stereo

Sink #62 State: RUNNING Name: alsa_output.usb-DisplayLink_Dell_D3100_USB3.0_Dock_1801300021-02.iec958-stereo Description: Dell D3100 USB3.0 Dock Digital Stereo (IEC958)

Sink #63 State: SUSPENDED Name: alsa_output.usb-Jabra_Jabra_UC_VOICE_550a_000100A9FCFE-00.analog-stereo Description: Jabra UC VOICE 550a Analog Stereo

So, it turned out that the Sink #63 was actually the default, which is exactly what the Gnome Settings Sound GUI was indicating. Resetting the default via pactl set-default-sink alsa_output.usb-DisplayLink_Dell_D3100_US... changed the indicator in the GUI also.

So, I think my remaining task is to see if I can adjust the resume from suspend procedure to set the default, in the case where I am connected to the dock. Probably, also I want to have the dock connection event to trigger the default setting too.

1

You can try to create udev rule https://www.freedesktop.org/wiki/Software/PulseAudio/Backends/ALSA/Profiles/#udevrule

or create systemd service like this https://wiki.parabola.nu/PulseAudio/Troubleshooting#No_sound_after_resume_from_suspend

to handle suspend

1
  • Thanks much! And, thanks Stack Exchange for enforcing a minimum comment length! Really? May 7 '20 at 21:10
0
+50

I had the some issue. Fixed by adding default output sink to ~/.profile

echo "pactl set-default-sink 'alsa_output.pci-0000_0c_00.4.analog-stereo'" |tee -a ~/.profile

Find you default sink with

pactl list sinks |grep Name |grep output | cut -d: -f2

You use USB, so USB-persist might be helpful

1
  • Hi ExploitFate. Thanks for the answer! I did mention in my original question that the default sink for PA, via pactl, is coming up correctly. The problem is that as far as Gnome goes, it is not the default sink. I do power off my dock when I suspend my laptop, so, the USB connection should be reset. There is no really issue as far as USB goes - everything gets connected fine. May 6 '20 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.