36

If i click on Ubuntu Software, it doesn't open. I have a fresh install of Ubuntu 20.04. I tried try to upgrade all packages, but it doesn't fix this problem.

If I try to run killall software-center there is no process with this name, and software-center returns command not found. If I try to reinstall it with apt I have these results:

$ sudo apt-get --purge --reinstall install software-center
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package oracle-java8-installer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'software-center' has no installation candidate
1

9 Answers 9

47

The Ubuntu Software Center (software-center) has been upgraded to GNOME Software (gnome-software) in Ubuntu 16.04 and later. The software app has also been renamed to Software in Ubuntu 20.04 and later.

If the Software app doesn't open run the following commands:

sudo apt clean # clean list of cached packages so Ubuntu Software can read them
sudo apt update && sudo apt upgrade
sudo apt autoremove gnome-software && sudo apt install gnome-software
9
  • thanks a lot, now i've software center working
    – tafazzi87
    Apr 28, 2020 at 8:58
  • 9
    Didn't work for me. Still the same problem.
    – GunJack
    May 29, 2020 at 10:26
  • 3
    However launching from the terminal works with the command gnome-software. Another problem is that the gnome-software shows around 500 MB of updates. While sudo apt update tells me that all the packages are up to date.
    – GunJack
    May 29, 2020 at 10:28
  • Make another desktop launcher and you can launch it from the Dash by clicking it. How can I create launchers on my desktop?. If you can't update that's a package management issue. You should ask a separate question about that.
    – karel
    May 29, 2020 at 10:29
  • 1
    You might need to reinstall some other pkgs uninstalled on the autoremove step, like the one from Flatpak, gnome-software-plugin-flatpak Mar 20 at 8:33
23

What is that doesn't work?

Is that gnome-software (see icon below)

screenshot

(If you hover your mouse over this on your dock/taskbar you get the tooltop Software. I didn't have this one docked to my taskbar on a fresh Ubuntu 20 installation.)

or snap-store? (see icon below)

screenshot

(the tooltip for this is Ubuntu Software).

To find out more information about why either of the 2 is failing, try to open them from a terminal:

  • Open a terminal (Ctrl + Alt + t, or windowsKeyand then search forterminal, or click on show applicationson your dock/taskbar and then search forterminal`)

  • Run them: gnome-software. Or snap-store.

Then, google again with the new information that you got.


A couple of ideas:

  • If if gnome-software is the one that doesn't work, you may try to follow karel instructions:

    sudo apt clean # clean list of cached packages so Ubuntu Software can read them
    sudo apt update && sudo apt upgrade
    sudo apt autoremove gnome-software && sudo apt install gnome-software
    
  • If snap-store is the one that is not working, I can tell you what was my problem (maybe you have a similar one). When I tried to run it I got a permission denied error:

    [...] WARNING: cannot create user data directory: 
    cannot create "/home/<username>/snap/snap-store/454": 
    mkdir /home/<username>/snap/snap-store: permission denied
    

this was happening because when I installed a fresh Ubuntu 20, I copied data from a backup of my previous system (CentOS), which had a snap directory inside my user's home directory. During the copying process, that directory got copied as owned by the root user.

(You can check the permissions, the user owner and the group of that directory with ls -al ~ | grep snap and similarly for what's inside with ls -al ~/snap)

To solve this I just changed the owner of my snap directory (and everything that was inside) with

sudo chown <myuser>:<mygroup> -R ~/snap

(replace <myuser> and <mygroup> with whatever are your user and group. E.g. bob:bob (or use the environment variable $USER). Use the ones that appear for almost everything you have inside your home, when running ls -al ~. Or check your user and its groups by running id).

After that I was able to run snap-store.

1
  • 1
    Was able to run gnome-software.
    – Tadej
    Jun 9, 2021 at 7:24
10

You can also try

sudo snap remove snap-store
sudo snap install snap-store

Remember it will ask for a password with pop-up

1
  • Thanks, this worked for me on 22.04 as well.
    – Jacob M.
    Sep 10 at 13:16
7

Try reinstalling it by using the below command, it worked for me after installing Ubuntu 20.04 today.

sudo apt-get --purge --reinstall install gnome-software

One more thing, I noticed that the 'Ubuntu Software' in my Dock was not working (it hangs). Even if I search for it under Application it hangs, I had to select 'Software' which has the same exact icon, that one works fine. Make sure you close Ubuntu Software before you run the command.

Let me know if that works for you. Good luck!

3

If you are referring to snap-store (the Ubuntu Software application), then I was getting the app failing silently on a brand new 20.04 install.

Typing "snap refresh snap-store" from the command line installed an updated version 467 (was previously 433) and everything worked after that.

1
  • This worked for me on a more or less fresh 20.04 install.
    – Kjetil S.
    Jun 5 at 12:21
2

Try using these commands in the terminal. It worked for me!

sudo apparmor_parser -r /etc/apparmor.d/*snap-confine*
sudo apparmor_parser -r /var/lib/snapd/apparmor/profiles/snap-confine*
sudo apparmor_parser -r /var/lib/snapd/apparmor/profiles/*
1
  • 1
    What does this do?
    – chx101
    Dec 24, 2021 at 6:33
1

Open terminal and:

gnome-software

This worked for me at least on "Ubuntu 20.04.2 LTS".

0

I had the same problem with snap-store so I installed gnome-software:

sudo apt install gnome-software

enter image description here

0

Try to install the candidate version. It worked for me.

First, remove the snap-store. It also removes your Software Center.

snap remove snap-store

then install the candidate version

snap install snap-store --candidate

enter image description here

or, you can use another alternative, Gnome Software

sudo apt install gnome-software

enter image description here

source : Ubuntu : Can't Open Software Center

Not the answer you're looking for? Browse other questions tagged or ask your own question.