33

I just updated to Ubuntu 20.04 LTS and my super key has lost its main functionality. Previously in Ubuntu 18.04LTS, I was able to click the super key and the applications drawer would show. Now it doesn't do that. I can still open it by clicking super+a but it's annoying that it doesn't do that.

I restarted my machine and still nothing.

5
  • 2
    To me, the super key stops working kind of randomly. Similarly, super+tab starts to ignore the shift key. And it seems connected with my keyboard stopping working completely in PhpStorm after pressing ctrl+shift. All started with Ubuntu 20.04. In most cases, trying to press around or restart an app (PhpStorm in this case) seems to fix the issue. Apr 27, 2020 at 16:31
  • I've restarted my pc and nothing happens I can click on the <kbd>super</kbd> + <kbd>a</kbd> but I don't want to keep doing that the super key by itself should work
    – rodude123
    Apr 27, 2020 at 16:47
  • Looks like the authors forgot to write or run regression tests :-(
    – dzieciou
    May 8, 2020 at 18:21
  • For me it was an keyboard issue. I unplugged my usb and put it in a different port. It start working again. It's worth a try ;)
    – Nieksa
    May 12, 2021 at 6:00
  • For anyone with a Dell developer edition laptop, see this solution.
    – Garrett
    Jul 18, 2021 at 8:19

7 Answers 7

29

Just in case anyone else is in the same situation as me and stumbles across this ...

check that your keyboard doesn't have a function button to lock the windows/super key. Mine did on f12 and I accidentally pressed it without knowing what it was. Just pressing it one more time fixed the issue ...

11
  • 11
    you saved my day
    – George
    Jun 11, 2021 at 8:14
  • 4
    Why the hell they have a button for this, I'm not sure. Jun 11, 2021 at 19:10
  • 2
    Exactly! i can't think of a good use for it lol
    – George
    Jun 12, 2021 at 9:43
  • 4
    mf ... that happend after i cleanned my keyboard, and you save my day Jun 21, 2021 at 12:16
  • 3
    This was the problem for me too! There's a button on my keyboard to disable the windows / super key. I know on mine because it's a gaming keyboard it's supposed to be used to stop you accidentally opening a menu in the middle of a game :)
    – BT643
    Aug 17, 2021 at 9:10
17

Pressing Fn+Super unblocked the Super key for me and solved the issue.

ROG Zephyrus G14, Ubuntu 21.04

5
  • 1
    Had the same problem and solution with an Asus TUF DASH F15 Jun 27, 2021 at 6:34
  • This was the solution on Ubuntu 18.04.
    – Arya
    Nov 23, 2021 at 17:11
  • 1
    this solution solved my problem, ubuntu 20.04
    – M Gholami
    Nov 23, 2021 at 21:54
  • wtf is Fn? d ds
    – pabrams
    Jan 17 at 3:58
  • Does Fn modify the super key into something else?
    – Sati
    Mar 27 at 4:06
16

I have the same issue but only when I select languages: Spanish, Italian, Russian. On English and French it works perfectly (which are in 1st and 4th position). As a workaround I put the two languages I use the most in 1st and 4th position, and for the rest I use ALT + F1 , that works in the same way... Hope the information helps.

5
  • 2
    This is exactly what my issue is, I use a keyboard with an American layout on it. I live in the UK and use the £ key a lot in online messages and so I have to keep switching keyboard layouts just for that. Only if there was an American keyboard layout with the £ symbol buitl in. That would be great.
    – rodude123
    May 2, 2020 at 17:44
  • The bug affects also the Keyboard Layout "English (US, intl., with dead keys)" but not "English (US)". Just as a reminder you can switch between keyboard layouts with <Super>+<Space> combination. Nice dude, you saved my day!
    – pliski
    May 6, 2020 at 11:00
  • Upgrading gnome-shell to version 3.36.2 fix the issue. Check the Diego Blanco answer Jun 7, 2020 at 11:57
  • I can confirm. I use English keyboard (super key works), but with Italian, Swedish and German keyboard it doesn't work. I will try to upgrade to see if this fixes the issue. Jun 27, 2020 at 10:27
  • I run update yesterday, but gnome-shell is still version 3.36.1. Jun 29, 2020 at 6:49
11

It seems to be a gnome bug affecting multiple distros. Here's the thread in gitlab

super no longer opens overview (with dvorak keyboard layout)

This all happens under X11. Temporary solution is to change to Wayland if possible or change the most used keyboard layout to first position.

The developers are aware of the issue and it may be patched soon.

EDIT: As of today, Ubuntu 20.04 is upgraded from Gnome 3.36.1 to 3.36.2 and a updated system should no longer have this issue.

  1. Just run

    sudo apt update
    
  2. Then run

    sudo apt upgrade
    

    Now gnome-shell --version should show:

    GNOME Shell 3.36.2
    
  3. Reboot system to apply changes: run sudo reboot or reboot manually.

3
  • I don't think there will be a propper solution until they fix the bug. For now this is the best we can do
    – rodude123
    Apr 28, 2020 at 14:32
  • 2
    7 Jun 2020: this fix works for ru layout Jun 7, 2020 at 11:55
  • Something other people might try: I just found out that by unplugging my keyboard I fixed this issue. :)
    – Nieksa
    Apr 12, 2021 at 9:54
3

So I managed to find a temporary fix for my problem. See I updated from Ubuntu 18.04, so not sure if this will help anyone updating from like 16.04, 17.04, 19.04 etc. Anyways the reason why I was having trouble with this is the fact that I have 2 keyboard layouts. I use an American and British layout. I am from the UK and always use the £ in everyday use. See, I have to switch layouts to use £ but then I forget to switch back to the original default layout, in this case, the American layout. At which point the super key stops working. I then try to get it to work for like 30 minutes to then only realise that oh wait I'm on not on the US layout. 😅 So I now use the English (intl., with AltGr dead keys)

4
  • 2
    Also this bug is relevant with Polish keyboard layout. Switching to En US is only option for now. May 8, 2020 at 10:34
  • @MaxMałecki How do you switching with a key shortcut between keyboard layouts?
    – dzieciou
    May 9, 2020 at 13:25
  • 3
    @MaxMałecki The default is Super+Space but you can change it under Settings > Keyboard Shortcuts > Typing .
    – Atzmon
    May 11, 2020 at 9:41
  • 1
    Edit: @Atzmon was first ;) on the top bar you got switch ;) Or you press [Super] + [Spacebar] May 11, 2020 at 9:44
1

If you have a Corsair K95 (or similar keyboard) there is a lock button to disable the Windows/super key.

-3

gnome guys fix this, just do

sudo apt-get update
sudo apt-get upgrade

to get the fix for the super key to work on sec layout

still didn't fix the launcher shortcut super+/

4
  • 3
    This doesn't do anything for me, and may not do anything for a lot of users
    – rodude123
    May 21, 2020 at 11:21
  • @rodude123 Did you upgrade your GNOME Shell to version 3.36.2?
    – pomsky
    May 22, 2020 at 8:50
  • I did upgrade it
    – rodude123
    May 22, 2020 at 9:23
  • This has nothing to do. May 26, 2020 at 2:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.