6

I tried everything I could find in the following links:
How can I enable Compose key?
https://help.ubuntu.com/community/ComposeKey
https://wiki.ubuntu.com/ComposeKey

However, I still could not get the compose key working on my freshly installed Ubuntu 20.04.

I use the english (US) keyboard layout, but I need to be able to type Umlauts with the compose key. In Ubuntu 18.04 and 16.04 it worked just fine and I mapped set and used the super key without any problems.

In 20.04 I tried different keys but none of them worked.

The output from gsettings get org.gnome.desktop.input-sources is:
xkb-options ['compose:rwin', 'eurosign:e', 'esperanto:qwerty'], however sudo vim /etc/dconf/db/local.d/00-input-sources contains compose:ralt...

  • ẏ€s īt døæs ... I used the method from using tweak tool, but I updated from 19.10, maybe the problem is setting the compose key ... – pLumo Apr 27 '20 at 10:20
  • I would actually like to map it to my right control, which I might have mistakenly thought to be the right super key? However, I tried it with right alt and it did not work, but the output of the command you provided says that this setting was not even recognized by the system so that might be the reason why right alt did not work... – ElectRocnic Apr 27 '20 at 13:16
  • 1
    Now I set it with tweak-tools to the right-control key and it works: Ö Ä Ü € ... nice, thanks! You pointed me in the right direction with the command. – ElectRocnic Apr 27 '20 at 13:18
  • You could add an answer with the command and that my output contains the wrong key, so I can mark yours as the correct one instead of my own... – ElectRocnic Apr 27 '20 at 13:19
3

Gunnar's comment pointed me into the right direction.

gsettings get org.gnome.desktop.input-sources shows the current active settings and therefore I was able to find out that I used the wrong key.

Using the gnome-tweak-tools I could update the settings accordingly to the right-ctrl which finally worked.

  • wow this is ... NOT how this works in September – Chaim Eliyah Sep 21 '20 at 4:16
  • Additionally requires sudo apt install gnome-tweaks since September 2020. – Simon A. Eugster Oct 12 '20 at 8:12
  • Is there any explanation for what changed since September 2020? As of November, my compose key (caps lock) stops working. In order to have it recognized again as compose, I have to reset and reapply the dconf setting: key=/org/gnome/desktop/input-sources/xkb-options; val=$(dconf read $key); dconf reset $key; dconf write $key $val; – Ben Mares Nov 6 '20 at 19:28
  • At least on 20.10, the command no longer works, however gsettings list-recursively org.gnome.desktop.input-sources does. – Marcel Waldvogel Nov 18 '20 at 7:17
  • In 20.04, there is this bug which caused settings not to be applied anymore. – Simon A. Eugster Dec 16 '20 at 7:45
0

If you prefer to use the command line, see this answer. Worked like a charm for me on U20.04.

If you prefer to use the GUI, and don't mind installing a package just for defining the compose key, see this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.