I have recently upgraded Ubuntu 19.10 to latest LTS Ubuntu 20.04. After updating, I get serious artifacts on my screen. Every time I reboot (or log-in), my screen is fuzzy or scrambled (picture attached):

fuzzy image

This is temporary. The fuzzy screen goes away when I change the background. But it reappears the moment I reboot or log back in.

I have Intel HD Graphics 520 (Skylake GT2).

The output of lspci -nn |grep -E 'VGA|Display' is:

00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07)


On enabling Wayland in Ubuntu 20.04 and logging in to, these artifacts are however cured.

This is okay for now, but I am not sure about Wayland as I have not yet used it before.

Is there a way to correct the graphic issue with normal Ubuntu startup?


3 Answers 3


I solved my fuzzy graphics issue which is related to Intel Drivers. A bug is also reported on Intel driver artifacts. Following the answer provided here this command line solved the issue:

sudo apt purge xserver-xorg-video-intel

Reboot and everything is back being normal.

clear window; no fuzzy graphics/artifacts

  • 1
    This solves the problem, thanks! Though I wonder if it forces the laptop to always use the nVidia GPU instead of the power-saving Intel one. May 5, 2020 at 21:56
  • 1
    In general, Wayland is newer and more secure. It stops apps from interfering with your cursor if it's not hovering over them and it doesn't allow apps to interfere with other apps. It's probably a good idea to use it instead of Xorg, and there's always Xwayland if you still need X for some reason.
    – S.S. Anne
    May 6, 2020 at 1:07
  • 1
    This solved my issue with Intel UHD 620 in Ubuntu 20.04. The best part is that I can keep my /etc/X11/xorg.conf.d/20-intel.conf with Option "TearFree" "true" to enable "vsync" and remove video tearing.
    – Jaakko
    Jul 16, 2020 at 16:21

Same problem here with an Intel UHD Graphics 630 (Desktop) after upgrading from 19.10 to 20.04.

Completely solved by deleting a custom Intel Xorg configuration file I had created in the past ― on my setup it was /etc/X11/xorg.conf.d/20-intel.conf, and contained:

Section "Device"
 Identifier "Intel Graphics"
 Driver "Intel"
 Option "AccelMethod" "sna"
 Option "TearFree" "true"
  • I have tried the solution. Even tried Option "AccelMethod" "uxa". But the results are same as before. There are glitches after reboot.
    – Tanvir
    Apr 29, 2020 at 5:45
  • 1
    thanks, I caused mine by askubuntu.com/questions/453109/…
    – FantomX1
    Feb 22, 2021 at 12:14
  • I have the same cards and custom config, but commenting it out made my system unable to boot. With that change undone, sudo apt purge xserver-xorg-video-intel did the trick.
    – hosford42
    Nov 17, 2021 at 2:46

I was having the same problem with ubuntu 20.04 so I updated ubuntu to 21.04 now the problem is solved

just try to update ubuntu to the current newer version it solves the problem

  • 1
    It might not be a proper solution to everybody to upgrade to a non-LTS release. May 13, 2021 at 8:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .