1

I installed Ubuntu 20.04 persistent on my usb. Every time boot, it starts disk checkup. I have to press Ctrl + C every time. I want to disable it permanently. And also for each shutdown it says press enter to remove installation medium.

5
4

Removing Disk Check on Persistent USB's

The command line option fsck.mode=skip can be used to skip the disk check.

The line Checking disks: 0% complete will still come up but fsck will not be run, nor will boot time be increased.

Edit the boot files below booted from a desktop or Live USB, not booted from the new persistent drive.

mkusb After the Persistent USB drive is created, open /boot/grub/grub.cfg as root.

  • Add fsck.mode=skip to the Persistent menuentry thus:

    linux   ($root)/casper/vmlinuz  file=/cdrom/preseed/ubuntu.seed maybe-ubiquity fsck.mode=skip quiet splash persistent ---
    
  • Newer versions of mkusb already include this fix.

  • If you also wish to remove the Try Ubuntu / Install Ubuntu screen delete "maybe-ubiquity".

UNetbootin After creating the boot drive, open /boot/grub/grub.cfg as root.

  • Add fsck.mode=skip to the first menuentry for (UEFI boot mode).

  • Open syslinux.cfg as root and add fsck.mode=skip to the default menuentry for (BIOS boot mode).

Rufus After creating the boot drive, open /boot/grub/grub.cfg as root.

  • Add fsck.mode=skip to the Default menuentry for (UEFI boot mode).

  • Open /isolinux/txt.cfg as root and add fsck.mode=skip to the "Try Ubuntu without installing" menuentry, (for BIOS boot mode).

The Try Ubuntu / Install Ubuntu screen can be removed from BIOS boot by overwriting syslinux.cfg with:

default persistent
label persistent
  say Booting an Ubuntu Persistent session...
  kernel /casper/vmlinuz
  append  file=/cdrom/preseed/ubuntu.seed boot=casper persistent initrd=/casper/initrd quiet splash noprompt --

The Try Ubuntu / Install Ubuntu screen can be removed from Rufus UEFI boot by removing "maybe-ubiquity" from /boot/grub/grub.cfg.

Edit 20200524: The above workaround is no longer needed.

This bug was fixed in the package casper - 1.447, as announced in: https://bugs.launchpad.net/ubuntu/+source/casper/+bug/1875548

Run:

sudo apt-get update
sudo apt-get install -y casper

I am still testing the fix.

8
  • Thanks to brian-murray for fsck.mode=skip – C.S.Cameron Apr 29 '20 at 7:37
  • 1
    Cannot find grub.cfg in /boot/grub/ . I used Rufus for installing persistent. – Tylore Apr 29 '20 at 9:53
  • @Tylore: I am running Rufus-3.10 with persistence and all default settings. If you are running the USB, /boot/grub/grub.cfg will be in /cdrom/ but that will be read only. To modify grub.cfg edit from Windows or another Live USB. – C.S.Cameron May 1 '20 at 3:59
  • @Tylore: I have edited the answer, thank you for pointing this out. – C.S.Cameron May 1 '20 at 4:42
  • @muru: Thank you for the edit but. Please explain why you say "it was just poorly formatted" and how adding a few spaces fixed it. I understand that the latest ISO uses multi space tabs where you show multiple spaces, however every example of a GRUB menuentry I can find on the Internet, including Official Ubuntu Documentation, shows single spaces in these locations, the same as I showed. I have been testing all morning and can find no advantage to adding spaces. – C.S.Cameron May 18 '20 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.