1

For some reason, way terminal colors are rendered seems to have changed after upgrading from 18.04 to 20.04. To take a concrete example, here's what terminator looks like in 18.04.

enter image description here

And here's what it looks like now.

enter image description here

I've checked, and the color profile I'm using in terminator is the exact same. I've even tried inputting custom colors on both machines, but it appears there's some sort of post-processing that happens that makes some colors darker in 20.04. I haven't done as much poking around in the gnome-terminal settings, but I'm getting the same output there. It doesn't seem to be dependent on the Ubuntu theme, because I've tried light and dark mode with the same results.

Anyone know what's going on and how I fix it?

2
  • Ah, progress. It looks like there was an option added to gnome-terminal to toggle showing bold text in a brighter color. The default used to be on; now it's off be default. Unfortunately, it looks like this change somehow affected terminator, but there's no option in terminator to set it back to the way it used to be. – Ellis Michael Apr 27 '20 at 4:25
  • i tried by right cliking on terminal >preferences >colors >uncheck use color scheme from system theme > and change the colors it worked for me – sassy.geek Jun 2 '20 at 3:49
3

Looks like it was a change to the default in VTE that affected gnome-terminal and terminator. As mentioned in the comment above, you can get back the old default (that bold colors are brighter) in gnome-terminal by checking the "Show bold text in bright colors" option.

There is currently no way to change this in terminator, but there's an active issue on Github. https://github.com/gnome-terminator/terminator/issues/38

0

I also noticed darker appearing colors compared to Ubuntu 18. However, I used a custom font, in my case Courier 10 Pitch on my Ubuntu 18 installation. After I installed this same font on my Ubuntu 20 and chose it on the Terminal, the colors appeared brighter.

0

to go back to what terminal colors looked like in 18.04,

  1. Go to Terminal Applications Preferences (using the hamburger menu icon in terminal app)
  2. Select a Profile from the left side ("Unnamed")
  3. Select Colors Tab
  4. check "Show bold text in bright colors" checkbox at the bottom

this should solve the issue

0

This is fixed in version 2.1.0 of terminator, which is already in hirsute. I tried the hirsute package and it works fine on 20.04.

After installing, enable 'Show bold text in bright colors' under Preferences -> Profiles -> Colors.

0

This is valid for gnome-terminal on Ubuntu 20.04 (Gnome v3.36.8).

I was used to the purple background from earlier versions. But now on 20.04 it's so dark it's nearly black, and the sharp contrast (including compared to my otherwise light desktop theme) disturbed me. (The background-color is additionally made to change based on whether the terminal window is currently focused or not.)

Now that I have learned about the "Show bold text in bright colors" option from other answers in this thread, my workaround idea to brighten the background color without having to extensively mess with system themes or terminal color schemes became viable.

Use this file (if it does not exist yet, then create it):

~/.config/gtk-3.0/gtk.css

Place this snippet into it:

terminal-window vte-terminal {
    background-color: #470732;
}

If you have just created this gtk.css file for the first time, then it's possible that a logout/login, or at least a gnome-shell-reload (Alt+F2 + r + Enter) is necessary for the new stylesheet to be introduced to the system.

The next time you open a terminal window this background will be used. Bonus: the background-color will not keep changing as you switch focus between different windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.