2

I noticed that Ubuntu 20 Release, comes with many unmet dependencies with some of them already deprecated and almost impossible to install. I see this when I try to install Packet Tracer and it outputs that requires many dependencies that at the same time need to install other dependencies.

Note: If you have a solution, I hope it worked out for you on a VM with Ubuntu 20 before suggesting it.

m@m:~/Desktop$ sudo dpkg -i PacketTracer_730_amd64.deb
Selecting previously unselected package packettracer.
(Reading database ... 207479 files and directories currently installed.)
Preparing to unpack PacketTracer_730_amd64.deb ...
Unpacking packettracer (7.3.0) ...
dpkg: dependency problems prevent configuration of packettracer:
 packettracer depends on libdouble-conversion1; however:
  Package libdouble-conversion1 is not installed.
 packettracer depends on qt-at-spi; however:
  Package qt-at-spi is not installed.

dpkg: error processing package packettracer (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu2) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Errors were encountered while processing:
 packettracer

EDIT: The main problem, is with qt-at-spi, libdouble-conversion1 I was able to install manually.

The following packages have unmet dependencies:
 qt-at-spi : Depends: libqt4-dbus (>= 4:4.8.0) but it is not installable
             Depends: libqtcore4 (>= 4:4.8~) but it is not installable
             Depends: libqtgui4 (>= 4:4.8~) but it is not installable
0
2

I had the same difficulty. After spending a few days googling and trying various suggestions, the following solved most of the problems.

  1. Downloaded and installed libdoule-conversion1 from this link: https://packages.ubuntu.com/bionic/libdouble-conversion1

  2. Downloaded PacketTracer_730_amd64.deb from https://www.netacad.com/portal/resources/packet-tracer

  3. Unpacked the .deb file and edited the file named control in the DEBIAN folder. I simply opened with text editor and deleted qt-at-spi from the "Depends: libdouble-conversion1, qt-at-spi" line, and saved, repacked as fixed.deb.

    Find detailed instructions here.

  4. Installed the fixed .deb.

  5. Rebooted.

Now Packet Tracer can only be launched from the terminal, the shortcut icon is not working. I remember seeing a solution for that somewhere, but I don't really mind.

6
  • It's generally a bad idea to delete dependencies from packages. They're listed there for a reason, and deleting them could lead to a crash or other inconvenience. – Nonny Moose May 19 '20 at 2:28
  • @NonnyMoose That's generally correct, however in this case matraven is correct because the qt-at-spi package is not required by most of the features in Packet Tracer. I made an improved formatting edit to this answer in case the downvote is yours and you decide to retract. This is a big problem in 20.04, and this answer is unique among all the answers that I have read. – karel May 19 '20 at 5:34
  • @karel My mistake. Does that mean that, technically, it should be an optional dependency? – Nonny Moose May 19 '20 at 18:13
  • @NonnyMoose Not having qt-at-sp installed disables one feature of Packet Tracer, so it is not an optional dependency even though the other features of Packet Tracer will work without it. – karel May 19 '20 at 19:23
  • I worked with this. its working nicely no errors – Prasad Jul 29 '20 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.