31

Installed Ubuntu 20.04 and I do not have sound.

I already tried many ways to solve it but the problem persists. When i run alsa mixer this comes out.

alsa mixer

1
  • I have the following issue: sound diminished until it just disappear (more less after two seconds). I cannot figure it out how to solve this. Any help would be appreciated.
    – Newbie
    Jan 6, 2021 at 0:39

9 Answers 9

33
sudo apt-get remove timidity
sudo shutdown now -r

That's all, problem solved.

11
  • 2
    # sudo apt-get remove timidity !!! May 3, 2020 at 2:58
  • 3
    I also had same problem, tried a bunch of other fixes but only this worked. Any idea what timidity was doing? Glad it worked, but why?
    – Boon
    May 24, 2020 at 9:42
  • 4
    This works. sudo alsa force-reload (after every reboot) also works. Can someone please give an explanation what's the issue? The package description of timidity sounds harmless.
    – Jan
    Jun 23, 2020 at 19:26
  • 3
    explation of the problem: timidity locks the audio device and pulseaudio can not access the audio device. You can observe this error if you see "is busy: yes" if you use debug mode: "pulseaudio -vvv". Another symptom is that you see two users in the /etc/group for audio. See freedesktop.org/wiki/Software/PulseAudio/Documentation/User/…
    – mmehl
    Oct 24, 2020 at 13:51
  • 2
    Glad this worked for others, but in Kubuntu 20.04.2 (fresh install), audio doesn't work, but neither timidity nor timidity-daemon are installed. So this answer appears to be outdated.
    – MWB
    Feb 24, 2021 at 22:12
22

I had this same issue a few days back when I updated my system to kubuntu 20.04. All I needed to do was type alsactl restore into my console and my audio jack started functioning again.

Edit: I'd advise you to use a .desktop file or keep it handy another way, because you'll have to run this script whenever you plug in a pair of headphones.

3
  • 2
    Thank you so much! This fixed it for me. For the record, I've switched from Kubuntu 19.10 to Kubuntu 20.04. May 6, 2020 at 16:33
  • 1
    Works for me but I need to run this command every time I unplug and replug the headset
    – lovesh
    May 8, 2020 at 11:38
  • 1
    Up vote is not enough - thanks!! Jan 30, 2021 at 22:30
14

internal sound card not detected (dummy output) with Ubuntu 20.04. The solution to this "dummy out" regression is:

Form 1

  1. You must add options snd-hda-intel dmic_detect=0 at the end of /etc/modprobe.d/alsa-base.conf. Do not change anything else in this file! Type in your terminal: sudo nano /etc/modprobe.d/alsa-base.conf //then open nano text editor in the same terminal and add at the end options snd-hda-intel dmic_detect=0 ,then press Ctrl+o and press Enter, then Ctrl+x to close the editor.

  2. Edit /etc/modprobe.d/blacklist.conf as root and add the blacklist snd_soc_skl at the end of the file. You can do this with a single command, using (execute this command only once): Type in your terminal: sudo nano /etc/modprobe.d/blacklist.conf //then open nano text editor in the same terminal and add blacklist snd_soc_skl to the end, then press Ctrl+o and press Enter, then Ctrl+x to close the editor.

  3. After making these changes, restart your system with sudo reboot.

Form 2

  1. If the problem persists, you can try to upgrade the kernel to another version. In my case, the 5.6.0 kernel worked for me:

    //This link is for the 5.6.0 version https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.6/ //this link below is for you to download the version of the kernel that is stable and go to the folder https://kernel.ubuntu.com/~kernel-ppa/mainline/

  2. You will get a lot of files, but you will only download 4 deb files if your PC or laptop is 64-bit which are: linux-headers,linux-image,linux-modules and lastly the one that says all.deb for example:

    linux-headers-5.6.0-050600-generic_5.6.0-050600.202003292333_amd64.deb linux-image-unsigned-5.6.0-050600-generic_5.6.0-050600.202003292333_amd64. deb linux-modules-5.6.0-050600-generic_5.6.0-050600.202003292333_amd64.deb linux-headers-5.6.0-050600-generic_5.6.0-050600.202003292333_amd64.deb

    // They don't have to have the same numbers, but at least they have to say the name of the files I told you about and the .deb format

  3. After downloading them, put them in a single folder, if in the downloads folder there are no other files and only the 4 that you downloaded, it is no longer necessary to put them in a folder.

  4. Then in the folder where the downloaded files are, open the terminal in that folder or open the terminal program you have and run sudo -s enter your password then type cd ~/Downloads, then type sudo dpkg -i *.deb.

  5. After that restart and you should have sound.

3
  • 1
    Thank you so much, form 1 worked like a charm for me ! And god, I have tried everything before... Cheers
    – Alarid
    Jun 30, 2020 at 14:25
  • 1
    I wasn't sure if you meant "add snd-hda-intel dmic_detect=0 or options snd-hda-intel dmic_detect=0; Easier to just use sudo sh -c "grep -q 'dmic_detect=0' /etc/modprobe.d/alsa-base.conf || echo 'options snd-hda-intel dmic_detect=0' >> /etc/modprobe.d/alsa-base.conf" sudo sh -c "grep -q 'blacklist snd_soc_skl' /etc/modprobe.d/blacklist.conf || echo 'blacklist snd_soc_skl' >> /etc/modprobe.d/blacklist.conf" Feb 23, 2021 at 9:44
  • "Form 1" worked on Kubuntu 20.04.2. Thanks! Some kind of explanation would be useful. Why are those incantations necessary? Why doesn't the $#@#$ Kubuntu work out of the box?
    – MWB
    Feb 24, 2021 at 23:00
11

Can you check your sound settings? If the Output Device and Input Device drop-down lists in Sound Settings are empty then I suggest you do the following:

sudo apt-get remove --purge pulseaudio
sudo apt-get install pulseaudio
mv ~/.config/pulse ~/.config/new_pulse_conf

Reboot your pc!

The 3rd command just changes the pulse directory name. By changing the name you cause the pulse configuration to be reloaded. You have to reboot for the changes to take effect. I had the same issue with 20.04 today, fixed it by doing the same. Hope this helps.

4
  • 4
    does't worked for me. :( Apr 29, 2020 at 13:41
  • 1
    try but it doesn't work, this happens to me in all the distributions that use ubuntu install debian 10 to test and if the sound works Apr 30, 2020 at 0:30
  • 1
    Worked perfect after a sudden loss of sound and disappearance of the build in audio o/p device from the list of audio devices. My system:NAME="Ubuntu" VERSION="20.04.1 LTS (Focal Fossa)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 20.04.1 LTS" VERSION_ID="20.04" Nov 17, 2020 at 10:12
  • +1 worked for me. I didn't have to do sudo apt dist-upgrade May 14, 2021 at 3:07
2

Not saying this will work for you but it worked for me (20.04 only):

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

sudo apt-get update; \
sudo apt-get dist-upgrade; \
sudo apt-get install \
  pavucontrol linux-sound-base alsa-base \
  alsa-utils lightdm ubuntu-desktop \
  linux-image-$(uname -r) libasound2; \
sudo apt-get -y --reinstall install \
  linux-sound-base alsa-base alsa-utils \
  lightdm ubuntu-desktop  linux-image-$(uname -r) \
  libasound2; \
killall pulseaudio; \
rm -r ~/.pulse*; \
ubuntu-support-status || ubuntu-security-status; \
sudo usermod -aG $(cat /etc/group | \
  grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | \
  awk -F: '{print $1}' | \
  tr '\n' ',' | \
  sed 's:,$::g') $(whoami)

And as one long line:

sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop  linux-image-$(uname -r) libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop  linux-image-$(uname -r) libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status || ubuntu-security-status; sudo usermod -aG (cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g') $(whoami)
1
  • 1
    oneliner broken
    – sjas
    Dec 3, 2020 at 1:09
1

Pulseaudio does not start after the last software update. No sound and no readings in the sound setting. You can restart pulseaudio until the next system boot:

pulseaudio --start

I searched the descriptions for the pulseaudio setting.

And in the file:

/etc/pulse/client.conf

I deleted (as root) in the line below semicolon(;):

; autospawn = yes

After restarting Ubuntu, the thanks is detected correctly. Why is it working?

1

Based on DiosProFortnite v's answer:

# disable dmic_detect
sudo sh -c "grep -q 'dmic_detect=0' /etc/modprobe.d/alsa-base.conf || echo 'options snd-hda-intel dmic_detect=0' >> /etc/modprobe.d/alsa-base.conf"
# blacklist snd_soc_skl
sudo sh -c "grep -q 'blacklist snd_soc_skl' /etc/modprobe.d/blacklist.conf || echo 'blacklist snd_soc_skl' >> /etc/modprobe.d/blacklist.conf"

I cut-n-pasted these in and then rebooted when pulseaudio "lost" my audio card, (that had been working for years) and just presented "Dummy" in pavucontrol under the "Output Devices" tab.

I don't know if these commands helped or if just a reboot would have fixed the problem.

0

I upgraded from 18.04 to 20.04, there was not sound at all after the upgrade.

This solved it for me:

I edited /usr/share/pulseaudio/alsa-mixer/paths/analog-output-lineout.conf, and changed any "Element" section that has switch = off to switch = on (I didn't change those who were mute).

Then I rebooted and the sound restored.

I've found this solution here: https://itectec.com/ubuntu/ubuntu-no-sound-on-ubuntu-20-04/

0

I have tried every answer about this problem on stackoverflow but no one worked.
This is the solution that worked for me:

sudo apt-get update -y
sudo apt-get install -y gnome-alsamixer
alsamixer

Press F6 and find your sound card
By default I have HDA NVidia selected; but Chip is not match with my sound card. HDA NVidia Selected Card Alsamixer If I press F6 and choose another one I will see my Sound Card name after Chip: HD-Audio Generec We have to navigate to the Auto-Mute option by using Left/Right Arrow-Keys and then disable it by using Up/Down arrow key.

Note: This solution worked for me but may not work for you. Try all solutions you see until you repair your sound :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.