3

So I cannot install steam at all... It complains about many dependencies that can't be installed.

Steam says it needs: libgl1-mesa-dri:i386 libgl1:i386

Output of apt-cache policy libgl1-mesa-dri:i386 libgl1:i386

libgl1-mesa-dri:i386:
  Installed: (none)
  Candidate: 20.0.4-2ubuntu1
  Version table:
     20.0.4-2ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu focal/main i386 Packages
     19.2.8-0ubuntu0~19.10.3 -1
        100 /var/lib/dpkg/status
libgl1:i386:
  Installed: (none)
  Candidate: 1.3.1-1
  Version table:
     1.3.1-1 500
        500 http://us.archive.ubuntu.com/ubuntu focal/main i386 Packages

Output of sudo aptitude install libgl1-mesa-dri:i386 libgl1:i386

The following NEW packages will be installed:
  libatomic1:i386{a} libdrm-amdgpu1:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} libdrm-radeon1:i386{a} libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a} libexpat1:i386{a} 
  libffi7:i386{a} libgl1:i386 libgl1-mesa-dri:i386{b} libglapi-mesa:i386{ab} libglvnd0:i386{a} libglx-mesa0:i386{ab} libglx0:i386{a} libllvm9:i386{a} libpciaccess0:i386{a} 
  libsensors5:i386{a} libstdc++6:i386{a} libvulkan1:i386{a} libwayland-client0:i386{a} libx11-xcb1:i386{a} libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} libxcb-glx0:i386{a} 
  libxcb-present0:i386{a} libxcb-randr0:i386{a} libxcb-sync1:i386{a} libxdamage1:i386{a} libxfixes3:i386{a} libxshmfence1:i386{a} libxxf86vm1:i386{a} libzstd1:i386{a} 
  mesa-vulkan-drivers:i386{a} 
0 packages upgraded, 35 newly installed, 0 to remove and 0 not upgraded.
Need to get 30.1 MB of archives. After unpacking 382 MB will be used.
The following packages have unmet dependencies:
 libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 20.1~git2003140730.b93a19~oibaf~e) but 20.0.4-2ubuntu1 is to be installed
 libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 20.0.4-2ubuntu1) but 20.1~git2003140730.b93a19~oibaf~e is installed
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 20.1~git2003140730.b93a19~oibaf~e) but 20.0.4-2ubuntu1 is to be installed
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 20.0.4-2ubuntu1) but 20.1~git2003140730.b93a19~oibaf~e is installed
 libglx-mesa0 : Breaks: libglx-mesa0:i386 (!= 20.1~git2003140730.b93a19~oibaf~e) but 20.0.4-2ubuntu1 is to be installed
 libglx-mesa0:i386 : Breaks: libglx-mesa0 (!= 20.0.4-2ubuntu1) but 20.1~git2003140730.b93a19~oibaf~e is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libgl1:i386 [Not Installed]                        
2)     libgl1-mesa-dri:i386 [Not Installed]               
3)     libglapi-mesa:i386 [Not Installed]                 
4)     libglx-mesa0:i386 [Not Installed]                  
5)     libglx0:i386 [Not Installed]                       

If I try to say "No", aptitude offers to remove practically every package I have (including all stuff needed for KDE Plasma, Latte, etc.

Output of neofetch:

OS: Ubuntu 20.04 LTS x86_64 
Host: SVS1511BFXB C60AZDBR 
Kernel: 5.4.0-26-generic 
Uptime: 43 mins 
Packages: 3385 (dpkg), 3 (snap) 
Shell: zsh 5.8 
Resolution: 1920x1080 @ 59.94Hz, 1920x1080 @ 60.00Hz 
DE: Plasma 
WM: KWin 
WM Theme: Gently 
Theme: Gently [Plasma], Breeze-Dark [GTK2/3] 
Icons: MB-Cherry-Suru-GLOW [Plasma], MB-Cherry-Suru-GLOW [GTK2/3] 
CPU: Intel i7-3612QM (8) @ 3.100GHz [154.4°F] 
GPU: Intel 3rd Gen Core processor Graphics Controller 
GPU: NVIDIA GeForce GT 640M LE 
Memory: 2484MiB / 11880MiB (20%) [---============] 
GPU Driver: i915 
Font: Iosevka Nerd Font Regular 10 [Plasma], Iosevka Nerd Font, Light 10 [GTK2/3] 
Locale: en_US.UTF-8 

1 Answer 1

1

This is likely due to mismatched multiarch packages.

The most useful post I've found is this from @kisak:

The most common situation with Ubuntu is that a newer version of a 64 bit package got installed, but the package manager doesn't have the exact same version available for 32 bit. Debian's multiarch implementation requires that all 64 bit and 32 bit variants of a package have the exact same version. Apt won't automatically pull in an older 64 bit version of a package than what's installed in order to allow the 32 bit variant to proceed and simply tells the user it's not going to happen.

For me, it was an issue with libllvm11 after upgrade where I had a :amd64 version from a llvm-toolchain ppa. The :i386 version from the mesa ppa could not match it, which was shown by running this command:

$ apt policy libllvm11 libllvm11:i386

Only found which package was the problem by experimental install/remove and seeing what caused the entire desktop environment to want to uninstall.

In your case, I note you have mesa packages with the version 20.1~git2003140730.b93a19~oibaf~e which suggests they're from ppa:oibaf/graphics-drivers rather than the (similar) Valve ppa:kisak/kisak-mesa. So, it may be worth purging the existing graphics stack, and installing the other one to see if that's the cause.

sudo apt install ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers
sudo add-apt-repository ppa:kisak/kisak-mesa
sudo apt-get update
sudo apt-get dist-upgrade

That's a little destructive, so if you can work out the exact problem package(s) and downgrade first, that may be safer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.